summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-09 14:58:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-09 17:13:33 +0200
commitb4bd6c0f791764b3fbac7a3702c076d01c093283 (patch)
tree16db8e54462ea49f17115b2e7560a8f17b41e98a /app-editors
parent8b3e81fbdbed52211c1e2318d38b8789a6628561 (diff)
downloadgentoo-b4bd6c0f791764b3fbac7a3702c076d01c093283.tar.gz
gentoo-b4bd6c0f791764b3fbac7a3702c076d01c093283.tar.xz
app-editors/okteta: 0.26.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/okteta/Manifest1
-rw-r--r--app-editors/okteta/okteta-0.26.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/okteta/Manifest b/app-editors/okteta/Manifest
index f42069ed6d8..61bf2e09add 100644
--- a/app-editors/okteta/Manifest
+++ b/app-editors/okteta/Manifest
@@ -1,2 +1,3 @@
DIST okteta-0.25.5.tar.xz 953492 BLAKE2B ca8c40df7cf3fe40a4be6f6e2b9d1f787baa658910c3c14ced73f3f3d95c942c00ccfe559562b2e0330726723ffba8e4c7c526369453517e1fd45d3d5ce0336e SHA512 dfe45a2bc3b3fbbce8342e6282981a63a342aee47d0d90cf07449f6974ebdbac53adc7fa9f0b37a7d003370994233f002df277ecebdb6f4c03995ce50d1dbd71
DIST okteta-0.26.0.tar.xz 969968 BLAKE2B 2041269caf027c6641e53ac5b89f5bea7323639a78d6c340007cb29fc662afc9bf99a918b8fe3ab0fb5b7a2ebd5a6278350fc1d33011dbe0db32761be9268996 SHA512 a9fd4a2481003ea16248ac49faf5061e581977fe5ee532fa67207a071259889282b5d38e84ae2eaaf1a13101774ebe415d6f7861c3f422b8a3553c6ab3b344da
+DIST okteta-0.26.1.tar.xz 970532 BLAKE2B c04e0c4a2665f91cde26ee28b95f768f3074a08c8fd30920c75f3ce52fdfa717e3e6cea9acf87c3c5d53c830e5badb51faa2abcebd5b55839ea4ee52874a6d4c SHA512 fa4e841c77ae255e9936b29e30fa0bc1f65594898820652ac8ba78497658ec5ef78cadf8b4d33cab09b2ee8da1d75b84377be28680b2d91c5af2dcdfe5da95e3
diff --git a/app-editors/okteta/okteta-0.26.1.ebuild b/app-editors/okteta/okteta-0.26.1.ebuild
new file mode 100644
index 00000000000..26543662e04
--- /dev/null
+++ b/app-editors/okteta/okteta-0.26.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Hex editor by KDE"
+HOMEPAGE="https://www.kde.org/applications/utilities/okteta
+https://utils.kde.org/projects/okteta/"
+IUSE="crypt designer"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ crypt? ( app-crypt/qca:2[qt5(+)] )
+ designer? ( $(add_qt_dep designer) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOMIT_EXAMPLES=ON
+ $(cmake-utils_use_find_package crypt Qca-qt5)
+ -DBUILD_DESIGNERPLUGIN=$(usex designer)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ local myctestargs=( -j1 )
+
+ kde5_src_test
+}