summaryrefslogtreecommitdiff
path: root/app-emacs/dash/dash-2.14.1.ebuild
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-06-03 07:24:22 +0200
committerHans de Graaff <graaff@gentoo.org>2018-06-03 07:24:22 +0200
commit7016208b1ca83b43258781619d2e1e302d5ae10d (patch)
tree48a488891edb05f36fbf749e5926c8e4369cec26 /app-emacs/dash/dash-2.14.1.ebuild
parent5eef009b9c629f7eda795ccd3cb974c122cbe684 (diff)
downloadgentoo-7016208b1ca83b43258781619d2e1e302d5ae10d.tar.gz
gentoo-7016208b1ca83b43258781619d2e1e302d5ae10d.tar.xz
app-emacs/dash: add 2.14.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emacs/dash/dash-2.14.1.ebuild')
-rw-r--r--app-emacs/dash/dash-2.14.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/dash/dash-2.14.1.ebuild b/app-emacs/dash/dash-2.14.1.ebuild
new file mode 100644
index 00000000000..da2a16d87b0
--- /dev/null
+++ b/app-emacs/dash/dash-2.14.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="A modern list library for Emacs"
+HOMEPAGE="https://github.com/magnars/dash.el"
+SRC_URI="https://github.com/magnars/dash.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="sys-apps/texinfo"
+
+S="${WORKDIR}/${PN}.el-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="dash.texi"
+DOCS="README.md"
+
+src_test() {
+ ./run-tests.sh || die
+}