summaryrefslogtreecommitdiff
path: root/app-emacs/distel
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/distel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/distel')
-rw-r--r--app-emacs/distel/Manifest1
-rw-r--r--app-emacs/distel/distel-4.0.6.ebuild39
-rw-r--r--app-emacs/distel/files/50distel-gentoo.el4
-rw-r--r--app-emacs/distel/metadata.xml9
4 files changed, 53 insertions, 0 deletions
diff --git a/app-emacs/distel/Manifest b/app-emacs/distel/Manifest
new file mode 100644
index 00000000000..82b5aa91f5e
--- /dev/null
+++ b/app-emacs/distel/Manifest
@@ -0,0 +1 @@
+DIST distel-4.0.6.tar.gz 210257 SHA256 a80538fab51008f4821f687e7bcda98b7ab9e6e3ef7d695087505a2e40caa1e1 SHA512 510f82b6794379d89020d234462e09251e0db285ebc111eaf096e32a4e3619384650cb2b47ed68d38762a496504b58981c73ca5b930bd0eb1407aee9599c149f WHIRLPOOL e8fef7f804f98fdf7a1bb97cda97f7d4e471ec5ca01d112d80c1ebd2cede5c0bb8f5ac023407820843a61dec959f31755aa50a2faf34021c9b8aa48d4fe0bf45
diff --git a/app-emacs/distel/distel-4.0.6.ebuild b/app-emacs/distel/distel-4.0.6.ebuild
new file mode 100644
index 00000000000..e03848432b7
--- /dev/null
+++ b/app-emacs/distel/distel-4.0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Distributed Emacs Lisp for Erlang"
+HOMEPAGE="http://code.google.com/p/distel/
+ http://www.emacswiki.org/emacs/DistributedEmacsLisp"
+SRC_URI="https://github.com/massemanet/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+# "New BSD License" according to http://code.google.com/p/distel/
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/erlang-11.2.5[emacs]"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake base info
+ cd elisp || die
+ elisp-compile *.el
+}
+
+src_install() {
+ emake prefix="${ED}"/usr \
+ ELISP_DIR="${ED}${SITELISP}/${PN}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo doc/distel.info
+ dohtml doc/distel/*.html
+ dodoc AUTHORS ChangeLog NEWS README*
+ use doc && dodoc doc/gorrie02distel.pdf
+}
diff --git a/app-emacs/distel/files/50distel-gentoo.el b/app-emacs/distel/files/50distel-gentoo.el
new file mode 100644
index 00000000000..485b2dc2774
--- /dev/null
+++ b/app-emacs/distel/files/50distel-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'distel-erlang-mode-hook "distel" nil t)
+(add-hook 'erlang-mode-hook 'distel-erlang-mode-hook)
+(setq distel-ebin-directory "/usr/share/distel/ebin")
diff --git a/app-emacs/distel/metadata.xml b/app-emacs/distel/metadata.xml
new file mode 100644
index 00000000000..0eb0d94a3b4
--- /dev/null
+++ b/app-emacs/distel/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="google-code">distel</remote-id>
+ <remote-id type="github">massemanet/distel</remote-id>
+</upstream>
+</pkgmetadata>