summaryrefslogtreecommitdiff
path: root/app-emacs/mic-paren
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/mic-paren
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/mic-paren')
-rw-r--r--app-emacs/mic-paren/Manifest1
-rw-r--r--app-emacs/mic-paren/files/50mic-paren-gentoo.el10
-rw-r--r--app-emacs/mic-paren/metadata.xml12
-rw-r--r--app-emacs/mic-paren/mic-paren-3.11.ebuild19
4 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/mic-paren/Manifest b/app-emacs/mic-paren/Manifest
new file mode 100644
index 00000000000..308f265b603
--- /dev/null
+++ b/app-emacs/mic-paren/Manifest
@@ -0,0 +1 @@
+DIST mic-paren-3.11.el.xz 13992 SHA256 f70756d031a7645fe70fac7fa60e365f47f8e7e59f1b4d8f1826d3295b4d2b74 SHA512 ac896c425330935c0d6ae86eb65232c8fb6c463f6cf259c4bfd79023c3e25243d6b998e9f0ea5393ef1491ab0bf1d6fe5dd33278fec93ec3231603bb6e910b77 WHIRLPOOL 29cec9587f9823a9fd11668f2a2dd06fc23a60e10815a1018c7c73f13e50040d59c8dc22bf9e9db805ccc31f22b6cd4ac279d022b363b3b9c0e69b5f6c1fc2c5
diff --git a/app-emacs/mic-paren/files/50mic-paren-gentoo.el b/app-emacs/mic-paren/files/50mic-paren-gentoo.el
new file mode 100644
index 00000000000..f94136de054
--- /dev/null
+++ b/app-emacs/mic-paren/files/50mic-paren-gentoo.el
@@ -0,0 +1,10 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'paren-activate "mic-paren"
+ "Activates mic-paren parenthesis highlighting." t)
+(autoload 'paren-deactivate "mic-paren"
+ "Deactivates mic-paren parenthesis highlighting" t)
+(autoload 'paren-toggle-matching-paired-delimiter "mic-paren" nil t)
+(autoload 'paren-toggle-matching-quoted-paren "mic-paren" nil t)
+(autoload 'paren-toggle-open-paren-context "mic-paren" nil t)
+(autoload 'paren-forward-sexp "mic-paren" nil t)
+(autoload 'paren-backward-sexp "mic-paren" nil t)
diff --git a/app-emacs/mic-paren/metadata.xml b/app-emacs/mic-paren/metadata.xml
new file mode 100644
index 00000000000..7afdcc0fc87
--- /dev/null
+++ b/app-emacs/mic-paren/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Load this file, activate it and Emacs will display highlighting on whatever
+ parenthesis (and paired delimiter if you like this) matches the one before
+ or after point. This is an extension to the paren.el file distributed with
+ Emacs. The default behaviour is similar to paren.el but more sophisticated.
+ Normally you can try all default settings to enjoy mic-paren.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emacs/mic-paren/mic-paren-3.11.ebuild b/app-emacs/mic-paren/mic-paren-3.11.ebuild
new file mode 100644
index 00000000000..e1c5da3b54e
--- /dev/null
+++ b/app-emacs/mic-paren/mic-paren-3.11.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Advanced highlighting of matching parentheses"
+HOMEPAGE="http://www.gnuvola.org/software/j/mic-paren/
+ http://www.emacswiki.org/emacs/MicParen"
+# taken from http://www.gnuvola.org/software/j/mic-paren/mic-paren.el
+SRC_URI="mirror://gentoo/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"