summaryrefslogtreecommitdiff
path: root/app-emacs/mode-compile
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/mode-compile
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/mode-compile')
-rw-r--r--app-emacs/mode-compile/Manifest1
-rw-r--r--app-emacs/mode-compile/files/50mode-compile-gentoo.el5
-rw-r--r--app-emacs/mode-compile/metadata.xml8
-rw-r--r--app-emacs/mode-compile/mode-compile-2.29.1.ebuild18
4 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/mode-compile/Manifest b/app-emacs/mode-compile/Manifest
new file mode 100644
index 00000000000..35f72a72a54
--- /dev/null
+++ b/app-emacs/mode-compile/Manifest
@@ -0,0 +1 @@
+DIST mode-compile-2.29.1.tar.gz 22924 SHA256 9c7dafa3a5c5706316a01071a2769beeecf228d0831fceb53d27d4e47c9d0421 SHA512 bc43d9cae411f5177ce70c736041db74c6db1dc5b766b22b92227e9e1324d304276bd104d8e3cac9ff5a877fc48b6da5b904e1acdb6cca7396fc7c26cc572815 WHIRLPOOL 3980e43e28438f5eefbd1d8e689cc18d9cc922857ec3e32b58c6aa6d056cc6798c2094b65de28705db6dfc95e493a06858a208c536f2c9d217027d47c4b311a9
diff --git a/app-emacs/mode-compile/files/50mode-compile-gentoo.el b/app-emacs/mode-compile/files/50mode-compile-gentoo.el
new file mode 100644
index 00000000000..d8dc2734d77
--- /dev/null
+++ b/app-emacs/mode-compile/files/50mode-compile-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'mode-compile "mode-compile"
+ "Command to compile current buffer file based on the major mode" t)
+(autoload 'mode-compile-kill "mode-compile"
+ "Command to kill a compilation launched by `mode-compile'" t)
diff --git a/app-emacs/mode-compile/metadata.xml b/app-emacs/mode-compile/metadata.xml
new file mode 100644
index 00000000000..fd0567d9ae8
--- /dev/null
+++ b/app-emacs/mode-compile/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="github">emacsmirror/mode-compile</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/mode-compile/mode-compile-2.29.1.ebuild b/app-emacs/mode-compile/mode-compile-2.29.1.ebuild
new file mode 100644
index 00000000000..3ac3d8ab022
--- /dev/null
+++ b/app-emacs/mode-compile/mode-compile-2.29.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Smart command for compiling files according to major-mode"
+HOMEPAGE="https://github.com/emacsmirror/mode-compile
+ http://www.emacswiki.org/emacs/ModeCompile"
+SRC_URI="https://github.com/emacsmirror/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"