summaryrefslogtreecommitdiff
path: root/app-emacs/zenburn
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/zenburn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/zenburn')
-rw-r--r--app-emacs/zenburn/Manifest1
-rw-r--r--app-emacs/zenburn/files/50zenburn-gentoo.el4
-rw-r--r--app-emacs/zenburn/metadata.xml12
-rw-r--r--app-emacs/zenburn/zenburn-20110907.ebuild29
4 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/zenburn/Manifest b/app-emacs/zenburn/Manifest
new file mode 100644
index 00000000000..9e0260d1134
--- /dev/null
+++ b/app-emacs/zenburn/Manifest
@@ -0,0 +1 @@
+DIST zenburn-20110907.el.bz2 6979 SHA256 b376c33ea3f97678d59b7d8103c352899515f3a6e68ab7f294ab787d9b29abd5 SHA512 552f4a751ffadaf2f4174c7f722abc1fb7a8f84934df01f61c2d7cf653328ce8fd18473f0748eaa570ab9221544e5e9c81243e731a2fff5f2c9028b992163062 WHIRLPOOL ab857e75d79745bfbf79675d7b6a784fc3d5f63e7a34492a663de5b9be6606728c41a0711e2cb3038bae578fd2c187ffc0bd2b7d097adbba5a7fa64f4852d4e7
diff --git a/app-emacs/zenburn/files/50zenburn-gentoo.el b/app-emacs/zenburn/files/50zenburn-gentoo.el
new file mode 100644
index 00000000000..0844532b501
--- /dev/null
+++ b/app-emacs/zenburn/files/50zenburn-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'color-theme-zenburn "zenburn"
+ "Just some alien fruit salad to keep you in the zone." t)
+(defalias 'zenburn 'color-theme-zenburn)
diff --git a/app-emacs/zenburn/metadata.xml b/app-emacs/zenburn/metadata.xml
new file mode 100644
index 00000000000..47a77903d55
--- /dev/null
+++ b/app-emacs/zenburn/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Zenburn is a low-contrast color theme. It's easy for your eyes and
+ designed to keep you in the zone for long programming sessions.
+</longdescription>
+<upstream>
+ <remote-id type="github">dbrock/zenburn-el</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/zenburn/zenburn-20110907.ebuild b/app-emacs/zenburn/zenburn-20110907.ebuild
new file mode 100644
index 00000000000..0d06ea3518a
--- /dev/null
+++ b/app-emacs/zenburn/zenburn-20110907.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Zenburn color theme for Emacs"
+HOMEPAGE="http://slinky.imukuppi.org/zenburnpage/
+ https://github.com/dbrock/zenburn-el"
+# snapshot from upstream git repo
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-emacs/color-theme"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "To enable zenburn by default, initialise it in your ~/.emacs:"
+ elog " (color-theme-zenburn)"
+}