summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-06-11 18:27:18 +0200
committerUlrich Müller <ulm@gentoo.org>2018-06-11 18:28:54 +0200
commit68bc333509848bad6a24628582a77313bfffb713 (patch)
tree3458e40cc3393dc46484d8302d5fe1d190b6bc02 /app-emacs
parent3d85b892400fdf438fc89362dc73ba3433f3776c (diff)
downloadgentoo-68bc333509848bad6a24628582a77313bfffb713.tar.gz
gentoo-68bc333509848bad6a24628582a77313bfffb713.tar.xz
app-emacs/yc: Fix byte-compilation with Emacs 26.
Closes: https://bugs.gentoo.org/657914 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/yc/files/yc-5.2.1-emacs-26.patch11
-rw-r--r--app-emacs/yc/yc-5.2.1.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/app-emacs/yc/files/yc-5.2.1-emacs-26.patch b/app-emacs/yc/files/yc-5.2.1-emacs-26.patch
new file mode 100644
index 00000000000..19925c65c45
--- /dev/null
+++ b/app-emacs/yc/files/yc-5.2.1-emacs-26.patch
@@ -0,0 +1,11 @@
+--- a/yc.el
++++ b/yc.el
+@@ -2071,7 +2071,7 @@
+ ;; $BJ8@a$r;XDj$7$J$$>l9g!"8=:_$NJ8@a$,BP>]$H$J$k(B
+ ;; $BFI$_$r<hF@$7$?J8@a$O$=$NFI$_$r%-%c%C%7%e$9$k(B
+ ;; cut $B$,(B $BHs(Bnil $B$N>l9g!";XDjJ8@a0J9_$NFI$_$r:o=|$9$k(B
+-(defun yc-yomi (&optional idx &optional cut)
++(defun yc-yomi (&optional idx cut)
+ (if (integerp idx)
+ (yc-put-bunsetsu-yomi idx (yc-get-bunsetsu-yomi idx cut) cut)
+ (yc-put-bunsetsu-yomi yc-mark (yc-get-bunsetsu-yomi yc-mark cut) cut)))
diff --git a/app-emacs/yc/yc-5.2.1.ebuild b/app-emacs/yc/yc-5.2.1.ebuild
index eb6992a1aa2..22ccd0a3230 100644
--- a/app-emacs/yc/yc-5.2.1.ebuild
+++ b/app-emacs/yc/yc-5.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -16,6 +16,7 @@ IUSE=""
RDEPEND="app-i18n/canna"
+ELISP_PATCHES="${P}-emacs-26.patch"
SITEFILE="50${PN}-gentoo.el"
src_install() {