summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-01-22 21:00:31 +0800
committerIan Delaney <idella4@gentoo.org>2016-01-22 21:02:46 +0800
commitb6d9e1b28be0f0cfde49bedc39ddaca4a6afb1ab (patch)
tree0fd1ad1e6e0adee874343c95310d3d89a48fc4c3 /app-emacs
parentad840d896c38f62d9b6a37cf4daa724d4136425a (diff)
parent6aa35edd2d5b1448994d8f58f07910931ddc344a (diff)
downloadgentoo-b6d9e1b28be0f0cfde49bedc39ddaca4a6afb1ab.tar.gz
gentoo-b6d9e1b28be0f0cfde49bedc39ddaca4a6afb1ab.tar.xz
Merge remote-tracking branch 'remotes/sbraz/urlwatch'
Pull request: https://github.com/gentoo/gentoo/pull/705
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/pymacs/metadata.xml10
-rw-r--r--app-emacs/pymacs/pymacs-0.25-r2.ebuild51
2 files changed, 56 insertions, 5 deletions
diff --git a/app-emacs/pymacs/metadata.xml b/app-emacs/pymacs/metadata.xml
index 3f864cf6504..4f7be8f8a82 100644
--- a/app-emacs/pymacs/metadata.xml
+++ b/app-emacs/pymacs/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>emacs</herd>
-<herd>python</herd>
-<upstream>
- <remote-id type="github">pinard/Pymacs</remote-id>
-</upstream>
+ <herd>emacs</herd>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">pinard/Pymacs</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-emacs/pymacs/pymacs-0.25-r2.ebuild b/app-emacs/pymacs/pymacs-0.25-r2.ebuild
new file mode 100644
index 00000000000..15852acb6d4
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.25-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit elisp distutils-r1 vcs-snapshot
+
+DESCRIPTION="A tool that allows both-side communication beetween Python and Emacs Lisp"
+HOMEPAGE="http://www.emacswiki.org/emacs/PyMacs"
+SRC_URI="https://github.com/pinard/Pymacs/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="doc? ( >=dev-python/docutils-0.7
+ virtual/latex-base )"
+RDEPEND=""
+
+DISTUTILS_IN_SOURCE_BUILD=1
+SITEFILE="50${PN}-gentoo.el"
+
+# called by distutils-r1 for every python implementation
+python_configure() {
+ # pre-process the files but don't run distutils
+ emake PYSETUP=: PYTHON=${EPYTHON}
+}
+
+# called once
+python_compile_all() {
+ elisp_src_compile
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts emake RST2LATEX=rst2latex.py pymacs.pdf
+ fi
+}
+
+python_install_all() {
+ elisp_src_install
+
+ sed \
+ -e '/pymacs-python-command/s:"python.*:"python":g' \
+ -i "${ED}"/${SITELISP}/pymacs/pymacs.el || die
+ elisp-compile "${ED}"/${SITELISP}/pymacs/pymacs.el
+
+ distutils-r1_python_install_all
+ dodoc pymacs.rst
+ use doc && dodoc pymacs.pdf
+}