summaryrefslogtreecommitdiff
path: root/app-emulation/dlx
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/dlx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/dlx')
-rw-r--r--app-emulation/dlx/Manifest1
-rw-r--r--app-emulation/dlx/dlx-1.0.0-r1.ebuild34
-rw-r--r--app-emulation/dlx/dlx-1.0.0.ebuild23
-rw-r--r--app-emulation/dlx/metadata.xml8
4 files changed, 66 insertions, 0 deletions
diff --git a/app-emulation/dlx/Manifest b/app-emulation/dlx/Manifest
new file mode 100644
index 00000000000..e7401063461
--- /dev/null
+++ b/app-emulation/dlx/Manifest
@@ -0,0 +1 @@
+DIST dlx.tar.gz 112589 SHA256 34d102fd72b7bfebf846fe20f7529d603fa6e47911267f46fba27741f8f94a8f SHA512 99297f14f6716ada7a29b204723a0c951002529362a22f695b3647517462f43af563ea55467985dda3e21d79a14d46b84dbc9b22a8c0751fba49257e30f70a7f WHIRLPOOL 2f7f44abb08b9a0c0549d4e921ed9196e0cf81e5fc759778205e08d537cb526eedc96deeb2dfa72449946a71712ef83c4fd0e9cbe7a9ddeccb25bcf29cdf6ace
diff --git a/app-emulation/dlx/dlx-1.0.0-r1.ebuild b/app-emulation/dlx/dlx-1.0.0-r1.ebuild
new file mode 100644
index 00000000000..638b2a733fd
--- /dev/null
+++ b/app-emulation/dlx/dlx-1.0.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="DLX Simulator"
+HOMEPAGE="http://www.davidviner.com/dlx.php"
+SRC_URI="http://www.davidviner.com/${PN}/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ LINK="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/include/dlx /usr/share/dlx/examples
+ dobin masm mon dasm
+ insinto /usr/include/dlx
+ doins *.i auto.a
+ insinto /usr/share/dlx/examples
+ doins *.a hp.m
+ dodoc README.txt MANUAL.TXT
+}
diff --git a/app-emulation/dlx/dlx-1.0.0.ebuild b/app-emulation/dlx/dlx-1.0.0.ebuild
new file mode 100644
index 00000000000..3a5cea4ede5
--- /dev/null
+++ b/app-emulation/dlx/dlx-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+S=${WORKDIR}/dlx
+DESCRIPTION="DLX Simulator"
+HOMEPAGE="http://www.davidviner.com/dlx.php"
+SRC_URI="http://www.davidviner.com/dlx/dlx.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE=""
+DEPEND=""
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin masm mon dasm
+ dodoc README.txt MANUAL.TXT
+}
diff --git a/app-emulation/dlx/metadata.xml b/app-emulation/dlx/metadata.xml
new file mode 100644
index 00000000000..59e2b8f78cb
--- /dev/null
+++ b/app-emulation/dlx/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>