summaryrefslogtreecommitdiff
path: root/app-emulation/docker-proxy/docker-proxy-0.8.0_p20161111.ebuild
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-11-14 18:10:37 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-11-14 18:13:07 +0100
commite38d85d7f66b61cfa64c0ad28a401c1d1d5a886a (patch)
tree4bdd4cbc84db404783af0f19b0f57092a493478b /app-emulation/docker-proxy/docker-proxy-0.8.0_p20161111.ebuild
parentfdd29ac95e7272fd89bd0e4b9882f5c8e74d517a (diff)
downloadgentoo-e38d85d7f66b61cfa64c0ad28a401c1d1d5a886a.tar.gz
gentoo-e38d85d7f66b61cfa64c0ad28a401c1d1d5a886a.tar.xz
app-emulation/docker-proxy: Initial version
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-emulation/docker-proxy/docker-proxy-0.8.0_p20161111.ebuild')
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20161111.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20161111.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20161111.ebuild
new file mode 100644
index 00000000000..96b44ae9a14
--- /dev/null
+++ b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20161111.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+EGO_PN="github.com/docker/libnetwork"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT="57be722e077059d1ee0539be31743a3642ccbeb3"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="Docker container networking"
+HOMEPAGE="http://github.com/docker/libnetwork"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RDEPEND="!!<app-emulation/docker-1.13_rc1"
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" go build -o "bin/docker-proxy" ./cmd/proxy || die
+}
+
+src_install() {
+ dodoc ROADMAP.md README.md CHANGELOG.md
+ dobin bin/docker-proxy
+}