summaryrefslogtreecommitdiff
path: root/app-emulation/docker-registry
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-10-28 01:53:48 -0700
committerZac Medico <zmedico@gentoo.org>2016-10-28 01:53:48 -0700
commit0d405aaffd8b1b192e57155d837c788cac794216 (patch)
tree6731aa59710a597b3769b8dfb1f4f9a71466af78 /app-emulation/docker-registry
parentda66d193be2d327d8c6b1b90191ccc56d89348f3 (diff)
downloadgentoo-0d405aaffd8b1b192e57155d837c788cac794216.tar.gz
gentoo-0d405aaffd8b1b192e57155d837c788cac794216.tar.xz
app-emulation/docker-registry: version bump to 2.5.1
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-emulation/docker-registry')
-rw-r--r--app-emulation/docker-registry/Manifest1
-rw-r--r--app-emulation/docker-registry/docker-registry-2.5.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/docker-registry/Manifest b/app-emulation/docker-registry/Manifest
index 90af5e5244a..1917b2dd2a1 100644
--- a/app-emulation/docker-registry/Manifest
+++ b/app-emulation/docker-registry/Manifest
@@ -1 +1,2 @@
DIST docker-registry-2.5.0.tar.gz 1619051 SHA256 9b1b09bf0f54a37247a4d4532ceb1a3bc2381ac13a63a9a5989f374614517c1c SHA512 2c9b45a8fbceff32538b357b9bb42d86e6d21b664cffcfb476ed06177608f35cd81f6bfdb342df3edfdea2705569fcf5cba94be6a885ecaf69f68ff8569de781 WHIRLPOOL 6bb9d01c690c636e4069535253182bed0ccc8973c1682283376975f6d105338bbf21ca28900c74e12ceaf12427f3b381b7fac97d25c637a0596e30019f22d3b3
+DIST docker-registry-2.5.1.tar.gz 1604279 SHA256 d98ebca3518c17d95468b1d40b87861036001301a16a50563203e4b9af72c514 SHA512 5217e2ca361d71806c8ec4da1cf1c2c5dc4160b84c2a98feae50872342d0acf116768a3acf00769bafd66e73c9922c7fe97cbde51955d8aa1d1ed914de2e3d34 WHIRLPOOL 12db4c397f6309a57252cfe19a055f610567c526a05220c9b6ac0d7ff21863520cc126f95b34c8e48fb7ae6ba6a298d0e6b53bf4866cf13bf95fcfb591c538b7
diff --git a/app-emulation/docker-registry/docker-registry-2.5.1.ebuild b/app-emulation/docker-registry/docker-registry-2.5.1.ebuild
new file mode 100644
index 00000000000..cd832b42428
--- /dev/null
+++ b/app-emulation/docker-registry/docker-registry-2.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit golang-vcs-snapshot systemd user
+
+KEYWORDS="~amd64"
+EGO_PN="github.com/docker/distribution/..."
+EGIT_COMMIT="v${PV}"
+SRC_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Docker Registry 2.0"
+HOMEPAGE="https://${EGO_PN%/*}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.5"
+SVCNAME=registry
+
+pkg_setup() {
+ enewgroup ${SVCNAME}
+ enewuser ${SVCNAME} -1 -1 /dev/null ${SVCNAME}
+}
+
+src_compile() {
+ GOPATH="${S}" GO15VENDOREXPERIMENT=1 \
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
+}
+
+src_install() {
+ exeinto /usr/libexec/${PN}
+ doexe "${S}"/bin/*
+ insinto /etc/docker/registry
+ newins "${S}"/src/${EGO_PN%/*}/cmd/registry/config-example.yml config.yml.example
+ newinitd "${FILESDIR}/${SVCNAME}.initd" "${SVCNAME}"
+ newconfd "${FILESDIR}/${SVCNAME}.confd" "${SVCNAME}"
+ systemd_dounit "${FILESDIR}/${SVCNAME}.service"
+ keepdir /var/{lib,log}/${SVCNAME}
+ fowners ${SVCNAME}:${SVCNAME} /var/{lib,log}/${SVCNAME}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${SVCNAME}.logrotated" "${SVCNAME}"
+}