summaryrefslogtreecommitdiff
path: root/app-emulation/free42
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/free42
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/free42')
-rw-r--r--app-emulation/free42/Manifest1
-rw-r--r--app-emulation/free42/files/free42-1.5.5-fix-makefile.patch30
-rw-r--r--app-emulation/free42/free42-1.5.5.ebuild46
-rw-r--r--app-emulation/free42/metadata.xml19
4 files changed, 96 insertions, 0 deletions
diff --git a/app-emulation/free42/Manifest b/app-emulation/free42/Manifest
new file mode 100644
index 00000000000..bf0e040da8b
--- /dev/null
+++ b/app-emulation/free42/Manifest
@@ -0,0 +1 @@
+DIST free42-1.5.5.tgz 8160228 SHA256 2c5a16aa470de76185135c307add9b920a712e31269c471dd246b6cf9283e050 SHA512 97833c99a24c2b1f427b237469868d57734b919b6c69521b45de480bd5274f5427caac13b9ccf3b79674d63dabdeda58a8db4c23a184b72b04279acbdf7eff8f WHIRLPOOL d435befbf2d392222d1ef7907c7913e474da5c4997dfb84177be3ea0b3fc1d9c9b0ea41590810e78d38eb082216b28c907fe39613823d866b6a1ab4d531a6af2
diff --git a/app-emulation/free42/files/free42-1.5.5-fix-makefile.patch b/app-emulation/free42/files/free42-1.5.5-fix-makefile.patch
new file mode 100644
index 00000000000..8f73b4405e7
--- /dev/null
+++ b/app-emulation/free42/files/free42-1.5.5-fix-makefile.patch
@@ -0,0 +1,30 @@
+diff -Nuar a/gtk/Makefile b/gtk/Makefile
+--- a/gtk/Makefile 2014-06-21 19:46:55.000000000 +0200
++++ b/gtk/Makefile 2014-06-24 00:03:38.719906032 +0200
+@@ -19,7 +19,6 @@
+ -Wall \
+ -Wno-parentheses \
+ -Wno-write-strings \
+- -g \
+ -I/usr/X11R6/include \
+ -fno-exceptions \
+ -fno-rtti \
+@@ -30,14 +29,11 @@
+ -DDECIMAL_GLOBAL_ROUNDING_ACCESS_FUNCTIONS=1 \
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS=1 \
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1 \
+- -D_WCHAR_T_DEFINED
++ -D_WCHAR_T_DEFINED \
++ ${CXXFLAGS}
+
+-LDFLAGS = -L/usr/X11R6/lib
+-LIBS := gcc111libbid-$(shell uname -m).a -lXmu $(shell pkg-config --libs gtk+-2.0)
+-
+-ifeq "$(shell uname -s)" "Linux"
+-LDFLAGS += -Wl,--hash-style=both
+-endif
++LDFLAGS := -L/usr/X11R6/lib ${LDFLAGS}
++LIBS := gcc111libbid-$(shell uname -m).a -lXmu -lX11 -ldl -lpthread $(shell pkg-config --libs gtk+-2.0)
+
+ SRCS = shell_main.cc shell_skin.cc skins.cc keymap.cc shell_loadimage.cc \
+ shell_spool.cc core_main.cc core_commands1.cc core_commands2.cc \
diff --git a/app-emulation/free42/free42-1.5.5.ebuild b/app-emulation/free42/free42-1.5.5.ebuild
new file mode 100644
index 00000000000..608ed317c14
--- /dev/null
+++ b/app-emulation/free42/free42-1.5.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An HP-42S Calculator Simulator"
+HOMEPAGE="http://thomasokken.com/free42/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="alsa"
+
+DEPEND="dev-libs/atk
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+ alsa? ( media-libs/alsa-lib )"
+
+RDEPEND="${DEPEND}
+ x11-libs/libX11
+ x11-libs/libXmu"
+
+S="${WORKDIR}/${PN}-nologo-${PV}"
+
+src_prepare() {
+ sed -i -e 's/print_gif_name\[FILENAMELEN\]/print_gif_name\[1000\]/' \
+ "${S}/gtk/shell_main.cc" || die
+ epatch "${FILESDIR}"/${P}-fix-makefile.patch
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C "${S}/gtk"
+}
+
+src_install() {
+ dodoc CREDITS HISTORY README TODO
+ dobin gtk/free42dec
+}
diff --git a/app-emulation/free42/metadata.xml b/app-emulation/free42/metadata.xml
new file mode 100644
index 00000000000..ae876330a77
--- /dev/null
+++ b/app-emulation/free42/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>nimiux@gentoo.org</email>
+ <name>Chema Alonso</name>
+ </maintainer>
+ <longdescription lang="en">
+ An HP-42S Calculator Simulator
+ </longdescription>
+ <longdescription lang="es">
+ Un simulador de la calculadora HP-42S
+ </longdescription>
+ <use>
+ <flag name="alsa">
+ Adds support for Advanced Linux Sound Architecture
+ </flag>
+ </use>
+</pkgmetadata>