summaryrefslogtreecommitdiff
path: root/app-emulation/libvirt
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-01-22 09:55:05 -0600
committerMatthias Maier <tamiko@gentoo.org>2017-01-22 10:28:25 -0600
commit875198b0bffbe4060ddb3c3bedb52632c80a6ba7 (patch)
treed589796713af870b4f968c47075e3c184301094b /app-emulation/libvirt
parent5409644d70cd632a301dec303c44c63cfff067ce (diff)
downloadgentoo-875198b0bffbe4060ddb3c3bedb52632c80a6ba7.tar.gz
gentoo-875198b0bffbe4060ddb3c3bedb52632c80a6ba7.tar.xz
app-emulation/libvirt: Do not create qemu user if USE=-qemu, bug #601678
Package-Manager: Portage-2.3.0, Repoman-2.3.1
Diffstat (limited to 'app-emulation/libvirt')
-rw-r--r--app-emulation/libvirt/libvirt-1.3.5-r2.ebuild14
-rw-r--r--app-emulation/libvirt/libvirt-2.1.0-r2.ebuild14
-rw-r--r--app-emulation/libvirt/libvirt-2.3.0.ebuild14
-rw-r--r--app-emulation/libvirt/libvirt-2.5.0-r2.ebuild12
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild12
5 files changed, 18 insertions, 48 deletions
diff --git a/app-emulation/libvirt/libvirt-1.3.5-r2.ebuild b/app-emulation/libvirt/libvirt-1.3.5-r2.ebuild
index 780322798a6..5f11f0c6bd3 100644
--- a/app-emulation/libvirt/libvirt-1.3.5-r2.ebuild
+++ b/app-emulation/libvirt/libvirt-1.3.5-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -125,15 +125,9 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
pkg_setup() {
- enewgroup qemu 77
- enewuser qemu 77 -1 -1 "qemu,kvm"
-
- # Some people used the masked ebuild which was not adding the qemu
- # user to the kvm group originally. This results in VMs failing to
- # start for some users. bug #430808
- egetent group kvm | grep -q qemu
- if [[ $? -ne 0 ]]; then
- gpasswd -a qemu kvm
+ if use qemu; then
+ enewgroup qemu 77
+ enewuser qemu 77 -1 -1 "qemu,kvm"
fi
# Check kernel configuration:
diff --git a/app-emulation/libvirt/libvirt-2.1.0-r2.ebuild b/app-emulation/libvirt/libvirt-2.1.0-r2.ebuild
index 24c8f326286..f9d91d7eba5 100644
--- a/app-emulation/libvirt/libvirt-2.1.0-r2.ebuild
+++ b/app-emulation/libvirt/libvirt-2.1.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -124,15 +124,9 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
pkg_setup() {
- enewgroup qemu 77
- enewuser qemu 77 -1 -1 "qemu,kvm"
-
- # Some people used the masked ebuild which was not adding the qemu
- # user to the kvm group originally. This results in VMs failing to
- # start for some users. bug #430808
- egetent group kvm | grep -q qemu
- if [[ $? -ne 0 ]]; then
- gpasswd -a qemu kvm
+ if use qemu; then
+ enewgroup qemu 77
+ enewuser qemu 77 -1 -1 "qemu,kvm"
fi
# Check kernel configuration:
diff --git a/app-emulation/libvirt/libvirt-2.3.0.ebuild b/app-emulation/libvirt/libvirt-2.3.0.ebuild
index 7d3cd016afd..96b318e307d 100644
--- a/app-emulation/libvirt/libvirt-2.3.0.ebuild
+++ b/app-emulation/libvirt/libvirt-2.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -124,15 +124,9 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
pkg_setup() {
- enewgroup qemu 77
- enewuser qemu 77 -1 -1 "qemu,kvm"
-
- # Some people used the masked ebuild which was not adding the qemu
- # user to the kvm group originally. This results in VMs failing to
- # start for some users. bug #430808
- egetent group kvm | grep -q qemu
- if [[ $? -ne 0 ]]; then
- gpasswd -a qemu kvm
+ if use qemu; then
+ enewgroup qemu 77
+ enewuser qemu 77 -1 -1 "qemu,kvm"
fi
# Check kernel configuration:
diff --git a/app-emulation/libvirt/libvirt-2.5.0-r2.ebuild b/app-emulation/libvirt/libvirt-2.5.0-r2.ebuild
index edc6c59f2b1..9f9134680d1 100644
--- a/app-emulation/libvirt/libvirt-2.5.0-r2.ebuild
+++ b/app-emulation/libvirt/libvirt-2.5.0-r2.ebuild
@@ -130,15 +130,9 @@ PATCHES=(
)
pkg_setup() {
- enewgroup qemu 77
- enewuser qemu 77 -1 -1 "qemu,kvm"
-
- # Some people used the masked ebuild which was not adding the qemu
- # user to the kvm group originally. This results in VMs failing to
- # start for some users. bug #430808
- egetent group kvm | grep -q qemu
- if [[ $? -ne 0 ]]; then
- gpasswd -a qemu kvm
+ if use qemu; then
+ enewgroup qemu 77
+ enewuser qemu 77 -1 -1 "qemu,kvm"
fi
# Check kernel configuration:
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index 609bf97449e..81795e4a7f6 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -130,15 +130,9 @@ PATCHES=(
)
pkg_setup() {
- enewgroup qemu 77
- enewuser qemu 77 -1 -1 "qemu,kvm"
-
- # Some people used the masked ebuild which was not adding the qemu
- # user to the kvm group originally. This results in VMs failing to
- # start for some users. bug #430808
- egetent group kvm | grep -q qemu
- if [[ $? -ne 0 ]]; then
- gpasswd -a qemu kvm
+ if use qemu; then
+ enewgroup qemu 77
+ enewuser qemu 77 -1 -1 "qemu,kvm"
fi
# Check kernel configuration: