summaryrefslogtreecommitdiff
path: root/app-emulation/qemu
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-03-09 13:06:23 -0600
committerMatthias Maier <tamiko@gentoo.org>2017-03-09 13:08:21 -0600
commitf732fbdd6ab148b548dce077f8581695735484d5 (patch)
tree846997a4f1b216b1f774afa7f4aebaf43b5d33b1 /app-emulation/qemu
parent1f43b2f2d0edefd1a072b999bac99df38b5e1a8d (diff)
downloadgentoo-f732fbdd6ab148b548dce077f8581695735484d5.tar.gz
gentoo-f732fbdd6ab148b548dce077f8581695735484d5.tar.xz
app-emulation/qemu: use pax-mark "mr" instead of pax-mark "m", bug #575594
Package-Manager: Portage-2.3.3, Repoman-2.3.2
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-2.8.0-r7.ebuild2
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/app-emulation/qemu/qemu-2.8.0-r7.ebuild b/app-emulation/qemu/qemu-2.8.0-r7.ebuild
index 4e09e1aca5f..2088438d8e5 100644
--- a/app-emulation/qemu/qemu-2.8.0-r7.ebuild
+++ b/app-emulation/qemu/qemu-2.8.0-r7.ebuild
@@ -678,7 +678,7 @@ src_install() {
# Disable mprotect on the qemu binaries as they use JITs to be fast #459348
pushd "${ED}"/usr/bin >/dev/null
- pax-mark m "${softmmu_bins[@]}" "${user_bins[@]}"
+ pax-mark mr "${softmmu_bins[@]}" "${user_bins[@]}" # bug 575594
popd >/dev/null
# Install config file example for qemu-bridge-helper
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 5e9a34ada3b..c208a1d924b 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -657,7 +657,7 @@ src_install() {
# Disable mprotect on the qemu binaries as they use JITs to be fast #459348
pushd "${ED}"/usr/bin >/dev/null
- pax-mark m "${softmmu_bins[@]}" "${user_bins[@]}"
+ pax-mark mr "${softmmu_bins[@]}" "${user_bins[@]}" # bug 575594
popd >/dev/null
# Install config file example for qemu-bridge-helper