summaryrefslogtreecommitdiff
path: root/app-emulation/qemu
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-03-04 10:06:19 -0600
committerMatthias Maier <tamiko@gentoo.org>2017-03-04 10:09:39 -0600
commitfe801faa69cb147f4fcf2c112e8275f7da935b3d (patch)
treeb05a1e7206a40e9ac419104da45e3373f604f986 /app-emulation/qemu
parentb3f2f902cde7ffefeaef47168d0ce7000a2fa13c (diff)
downloadgentoo-fe801faa69cb147f4fcf2c112e8275f7da935b3d.tar.gz
gentoo-fe801faa69cb147f4fcf2c112e8275f7da935b3d.tar.xz
app-emulation/qemu: fix inverted logic in configure stage, bug #611238
Package-Manager: Portage-2.3.3, Repoman-2.3.2
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-2.8.0-r6.ebuild6
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/app-emulation/qemu/qemu-2.8.0-r6.ebuild b/app-emulation/qemu/qemu-2.8.0-r6.ebuild
index 9c2b891c89e..584a2e15773 100644
--- a/app-emulation/qemu/qemu-2.8.0-r6.ebuild
+++ b/app-emulation/qemu/qemu-2.8.0-r6.ebuild
@@ -413,10 +413,10 @@ qemu_src_configure() {
# Disable options not used by user targets as the default configure
# options will autoprobe and try to link in a bunch of unused junk.
conf_softmmu() {
- if [[ ${buildtype} == "user" ]] ; then
- echo "--disable-${2:-$1}"
- else
+ if [[ ${buildtype} == "softmmu" ]] ; then
use_enable "$@"
+ else
+ echo "--disable-${2:-$1}"
fi
}
conf_opts+=(
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 580f45bfabd..46221a38b07 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -392,10 +392,10 @@ qemu_src_configure() {
# Disable options not used by user targets as the default configure
# options will autoprobe and try to link in a bunch of unused junk.
conf_softmmu() {
- if [[ ${buildtype} == "user" ]] ; then
- echo "--disable-${2:-$1}"
- else
+ if [[ ${buildtype} == "softmmu" ]] ; then
use_enable "$@"
+ else
+ echo "--disable-${2:-$1}"
fi
}
conf_opts+=(