summaryrefslogtreecommitdiff
path: root/app-emulation/qtemu/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/qtemu/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/qtemu/files')
-rw-r--r--app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch b/app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch
new file mode 100644
index 00000000000..8fc1680aacb
--- /dev/null
+++ b/app-emulation/qtemu/files/1.0.5-help_and_translation_paths.patch
@@ -0,0 +1,63 @@
+diff -Naur qtemu-1.0.5.orig/CMakeLists.txt qtemu-1.0.5/CMakeLists.txt
+--- qtemu-1.0.5.orig/CMakeLists.txt 2008-02-22 19:32:43.000000000 +0100
++++ qtemu-1.0.5/CMakeLists.txt 2008-02-22 19:35:29.000000000 +0100
+@@ -114,7 +114,7 @@
+ DEPENDS ${QM_FILES})
+
+ INSTALL (FILES ${QM_FILES}
+- DESTINATION translations)
++ DESTINATION share/qtemu/translations)
+ # translation end
+
+ SET(QT_USE_QTXML)
+@@ -146,13 +146,13 @@
+ )
+
+ FILE(GLOB helpfiles "${CMAKE_CURRENT_SOURCE_DIR}/help/*.png")
+-INSTALL(FILES ${helpfiles} DESTINATION help)
++INSTALL(FILES ${helpfiles} DESTINATION share/qtemu/help)
+
+-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/main.htm DESTINATION help)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/main.htm DESTINATION share/qtemu/help)
+
+ FILE(GLOB helpfiles_de "${CMAKE_CURRENT_SOURCE_DIR}/help/de/*.png")
+-INSTALL(FILES ${helpfiles_de} DESTINATION help/de)
++INSTALL(FILES ${helpfiles_de} DESTINATION share/qtemu/help/de)
+
+-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/de/main.htm DESTINATION help/de)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/help/de/main.htm DESTINATION share/qtemu/help/de)
+
+ INSTALL(TARGETS qtemu DESTINATION bin)
+diff -Naur qtemu-1.0.5.orig/helpwindow.cpp qtemu-1.0.5/helpwindow.cpp
+--- qtemu-1.0.5.orig/helpwindow.cpp 2008-02-22 19:32:44.000000000 +0100
++++ qtemu-1.0.5/helpwindow.cpp 2008-02-22 19:33:26.000000000 +0100
+@@ -80,7 +80,7 @@
+ return testUrl;
+
+ //check for case when qtemu executable is in bin/ (installed on linux)
+- testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../help/" + locale + "/main.htm");
++ testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../share/qtemu/help/" + locale + "/main.htm");
+ if (QFile::exists(testUrl.toString()))
+ return testUrl;
+ }
+@@ -96,7 +96,7 @@
+ return testUrl;
+
+ //check for case when qtemu executable is in bin/ (installed on linux)
+- testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../help/main.htm");
++ testUrl = QUrl(QCoreApplication::applicationDirPath()+"/../share/qtemu/help/main.htm");
+ if (QFile::exists(testUrl.toString()))
+ return testUrl;
+
+diff -Naur qtemu-1.0.5.orig/main.cpp qtemu-1.0.5/main.cpp
+--- qtemu-1.0.5.orig/main.cpp 2008-02-22 19:32:43.000000000 +0100
++++ qtemu-1.0.5/main.cpp 2008-02-22 19:36:32.000000000 +0100
+@@ -45,7 +45,7 @@
+ translator.load(path);
+ else
+ {
+- path = QCoreApplication::applicationDirPath()+"/../translations/qtemu_" + locale + ".qm";
++ path = QCoreApplication::applicationDirPath()+"/../share/qtemu/translations/qtemu_" + locale + ".qm";
+ if (QFile::exists(path))
+ translator.load(path);
+ }