summaryrefslogtreecommitdiff
path: root/app-emulation/runc/runc-0.1.1.ebuild
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-11-19 13:48:17 -0600
committerWilliam Hubbs <williamh@gentoo.org>2016-11-19 13:48:44 -0600
commit9cd25c21392af7f1e5d127acddb3dab73e5a4227 (patch)
tree23fbcdbe09c949fbeecf2c2aa6158d0f500fcfd0 /app-emulation/runc/runc-0.1.1.ebuild
parent0e06b41906f48d37444ea6c8457f67bde7551622 (diff)
downloadgentoo-9cd25c21392af7f1e5d127acddb3dab73e5a4227.tar.gz
gentoo-9cd25c21392af7f1e5d127acddb3dab73e5a4227.tar.xz
app-emulation/runc: remove unstable versions
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation/runc/runc-0.1.1.ebuild')
-rw-r--r--app-emulation/runc/runc-0.1.1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/app-emulation/runc/runc-0.1.1.ebuild b/app-emulation/runc/runc-0.1.1.ebuild
deleted file mode 100644
index 38f97f15d88..00000000000
--- a/app-emulation/runc/runc-0.1.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-EGO_PN="github.com/opencontainers/${PN}"
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- MY_PV="${PV/_/-}"
- EGIT_COMMIT="v${MY_PV}"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="runc container cli tools"
-HOMEPAGE="http://runc.io"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="apparmor +seccomp"
-
-DEPEND=""
-RDEPEND="
- apparmor? ( sys-libs/libapparmor )
- seccomp? ( sys-libs/libseccomp )
-"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-src_compile() {
- # Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
-
- # Setup GOPATH so things build
- rm -rf .gopath
- mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
- ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
- export GOPATH="${PWD}/.gopath:${PWD}/vendor"
-
- # build up optional flags
- local options=(
- $(usex apparmor 'apparmor')
- $(usex seccomp 'seccomp')
- )
-
- emake BUILDTAGS="${options[*]}"
-}
-
-src_install() {
- dobin runc
-}