summaryrefslogtreecommitdiff
path: root/app-emulation/runc/runc-0.1.1.ebuild
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-11-19 15:37:00 -0600
committerWilliam Hubbs <williamh@gentoo.org>2016-11-19 15:37:00 -0600
commitbeea75c4951aa78427db7289cfa858a6fe20cd35 (patch)
tree1b444f0c280fc4b1598496bee0d05bf4ad71e721 /app-emulation/runc/runc-0.1.1.ebuild
parent777688951a6a393123ae27c6713f5fd8e59e787a (diff)
downloadgentoo-beea75c4951aa78427db7289cfa858a6fe20cd35.tar.gz
gentoo-beea75c4951aa78427db7289cfa858a6fe20cd35.tar.xz
Revert "app-emulation/runc: remove unstable versions"
This reverts commit 9cd25c21392af7f1e5d127acddb3dab73e5a4227. We need these until I look at containerd
Diffstat (limited to 'app-emulation/runc/runc-0.1.1.ebuild')
-rw-r--r--app-emulation/runc/runc-0.1.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/runc/runc-0.1.1.ebuild b/app-emulation/runc/runc-0.1.1.ebuild
new file mode 100644
index 00000000000..38f97f15d88
--- /dev/null
+++ b/app-emulation/runc/runc-0.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+EGO_PN="github.com/opencontainers/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ EGIT_COMMIT="v${MY_PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="runc container cli tools"
+HOMEPAGE="http://runc.io"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor +seccomp"
+
+DEPEND=""
+RDEPEND="
+ apparmor? ( sys-libs/libapparmor )
+ seccomp? ( sys-libs/libseccomp )
+"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_compile() {
+ # Taken from app-emulation/docker-1.7.0-r1
+ export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
+
+ # Setup GOPATH so things build
+ rm -rf .gopath
+ mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
+ ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
+ export GOPATH="${PWD}/.gopath:${PWD}/vendor"
+
+ # build up optional flags
+ local options=(
+ $(usex apparmor 'apparmor')
+ $(usex seccomp 'seccomp')
+ )
+
+ emake BUILDTAGS="${options[*]}"
+}
+
+src_install() {
+ dobin runc
+}