summaryrefslogtreecommitdiff
path: root/app-emulation/winetricks/winetricks-20190310.ebuild
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-03-10 15:21:09 +0200
committerNick Sarnie <sarnex@gentoo.org>2019-03-10 10:45:06 -0400
commita43f60e1a7ed5238f444e2359ea670fe325cd755 (patch)
tree44d0cbfbb37e67678e146d15c8060e09967520fe /app-emulation/winetricks/winetricks-20190310.ebuild
parent6a0ab7215f7c1c4d36579184647bdbf5fd8dcba6 (diff)
downloadgentoo-a43f60e1a7ed5238f444e2359ea670fe325cd755.tar.gz
gentoo-a43f60e1a7ed5238f444e2359ea670fe325cd755.tar.xz
app-emulation/winetricks: version bump to 20190310
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/winetricks/winetricks-20190310.ebuild')
-rw-r--r--app-emulation/winetricks/winetricks-20190310.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/app-emulation/winetricks/winetricks-20190310.ebuild b/app-emulation/winetricks/winetricks-20190310.ebuild
new file mode 100644
index 00000000000..900a5b53922
--- /dev/null
+++ b/app-emulation/winetricks/winetricks-20190310.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Winetricks/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Winetricks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+wtg="winetricks-gentoo-2012.11.24"
+
+SRC_URI="${SRC_URI}
+ gtk? ( https://dev.gentoo.org/~chiitoo/distfiles/${wtg}.tar.bz2 )
+ kde? ( https://dev.gentoo.org/~chiitoo/distfiles/${wtg}.tar.bz2 )
+"
+
+DESCRIPTION="Easy way to install DLLs needed to work around problems in Wine"
+HOMEPAGE="https://github.com/Winetricks/winetricks https://wiki.winehq.org/Winetricks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="gtk kde rar test"
+
+BDEPEND="
+ test? (
+ dev-python/bashate
+ dev-util/checkbashisms
+ dev-util/shellcheck
+ )
+"
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ net-misc/wget
+ virtual/wine
+ x11-misc/xdg-utils
+ gtk? ( gnome-extra/zenity )
+ kde? ( kde-apps/kdialog )
+ rar? ( app-arch/unrar )
+"
+
+# Test targets include syntax checks only, not the "heavy duty" tests
+# that would require a lot of disk space, as well as network access.
+
+# This uses a non-standard "Wine" category, which is provided by
+# '/etc/xdg/menus/applications-merged/wine.menu' from the
+# 'app-emulation/wine-desktop-common' package.
+# https://bugs.gentoo.org/451552
+QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]]; then
+ git-r3_src_unpack
+
+ if use gtk || use kde; then
+ unpack ${wtg}.tar.bz2
+ fi
+
+ else
+ default
+ fi
+}
+
+src_test() {
+ ./tests/shell-checks || die "Test(s) failed."
+}
+
+src_install() {
+ default
+
+ if use gtk || use kde; then
+ cd "${WORKDIR}/${wtg}" || die
+ domenu winetricks.desktop
+ insinto /usr/share/icons/hicolor/scalable/apps
+ doins wine-winetricks.svg
+ fi
+}