summaryrefslogtreecommitdiff
path: root/app-emulation/xen
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2015-12-05 23:14:37 -0600
committerDoug Goldstein <cardoe@gentoo.org>2015-12-05 23:35:10 -0600
commit8a11081f495114c5ddfb54a8cef9285d6d7aa878 (patch)
tree5cdb8487d7a76e8431e0772fb694b2a525361bc6 /app-emulation/xen
parent3fdeeac653938b76993db617b4a3786287ec2007 (diff)
downloadgentoo-8a11081f495114c5ddfb54a8cef9285d6d7aa878.tar.gz
gentoo-8a11081f495114c5ddfb54a8cef9285d6d7aa878.tar.xz
app-emulation/xen: provide a sub-slot
Technically when switching between minor versions (e.g. 4.5 -> 4.6) you need to rebuild anything that has linked against the Xen libraries due to no promise of ABI stability between those versions. So expose a sub-slot so packages can be rebuilt appropriately. Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/xen-4.6.0-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-emulation/xen/xen-4.6.0-r2.ebuild b/app-emulation/xen/xen-4.6.0-r2.ebuild
index bfe39a94a1a..717b3e1e0d4 100644
--- a/app-emulation/xen/xen-4.6.0-r2.ebuild
+++ b/app-emulation/xen/xen-4.6.0-r2.ebuild
@@ -6,10 +6,11 @@ EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit eutils mount-boot flag-o-matic python-any-r1 toolchain-funcs
+inherit eutils mount-boot flag-o-matic python-any-r1 toolchain-funcs versionator
MY_PV=${PV/_/-}
MY_P=${PN}-${PV/_/-}
+MAJOR_V="$(get_version_component_range 1-2)"
if [[ $PV == *9999 ]]; then
inherit git-r3
@@ -38,7 +39,7 @@ fi
DESCRIPTION="The Xen virtual machine monitor"
HOMEPAGE="http://xen.org/"
LICENSE="GPL-2"
-SLOT="0"
+SLOT="0/${MAJOR_V}"
IUSE="custom-cflags debug efi flask xsm"
DEPEND="${PYTHON_DEPS}