summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-23 15:58:17 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-03-23 15:58:17 +0100
commit493626d05e359ea4e988937c9502a01e159e2e5a (patch)
tree44d921242b99a459aea301a9c279d9d86d7f5340 /app-emulation
parent0b4daaa30907154c4f80875d5bf99604d233882e (diff)
downloadgentoo-493626d05e359ea4e988937c9502a01e159e2e5a.tar.gz
gentoo-493626d05e359ea4e988937c9502a01e159e2e5a.tar.xz
app-emulation/docker-proxy: Sync live ebuild
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-proxy/docker-proxy-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-emulation/docker-proxy/docker-proxy-9999.ebuild b/app-emulation/docker-proxy/docker-proxy-9999.ebuild
index e7cea4d03b2..99ad94f4c96 100644
--- a/app-emulation/docker-proxy/docker-proxy-9999.ebuild
+++ b/app-emulation/docker-proxy/docker-proxy-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,7 +9,7 @@ if [[ ${PV} == *9999 ]]; then
else
EGIT_COMMIT=""
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64"
+ KEYWORDS="~amd64 ~arm ~ppc64"
inherit golang-vcs-snapshot
fi
@@ -24,8 +24,10 @@ S=${WORKDIR}/${P}/src/${EGO_PN}
RDEPEND="!<app-emulation/docker-1.13.0_rc1"
+RESTRICT="test" # needs dockerd
+
src_compile() {
- GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" go build -o "bin/docker-proxy" ./cmd/proxy || die
+ GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
}
src_install() {