summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-11-25 08:40:32 -0600
committerAlex Brandt <alunduil@gentoo.org>2015-11-25 08:41:11 -0600
commit6d4b41d7904e388e9e65581157eceadd5e18c5af (patch)
tree9c4a42c229faed068e83d17477bb2f470d6ab510 /app-emulation
parent87ffc25df4429f9313f5df729563a8956ba19508 (diff)
downloadgentoo-6d4b41d7904e388e9e65581157eceadd5e18c5af.tar.gz
gentoo-6d4b41d7904e388e9e65581157eceadd5e18c5af.tar.xz
app-emulation/docker-compose: move enum34 dependence
The dev-python/enum34 dependence was in the incorrect set of dependencies. I read the setup.py incorrectly and placed it in testing dependences rather than common. This fixes bug #566754. Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-compose/docker-compose-1.5.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-emulation/docker-compose/docker-compose-1.5.1.ebuild b/app-emulation/docker-compose/docker-compose-1.5.1.ebuild
index e988d1938a4..e20684f2665 100644
--- a/app-emulation/docker-compose/docker-compose-1.5.1.ebuild
+++ b/app-emulation/docker-compose/docker-compose-1.5.1.ebuild
@@ -36,13 +36,13 @@ CDEPEND="
<dev-python/texttable-0.9[${PYTHON_USEDEP}]
>=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
<dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
"
DEPEND="
test? (
${CDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
$(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
)
"