summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-11-24 14:41:42 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-11-24 14:41:42 +0100
commit94996ce62b0327bd8194f65d2ab9900fd78ed88e (patch)
tree466751840bc98ee1b6a9794d04ee0d974c7af987 /app-emulation
parentb33e8014440a1a1d4db849568046acaa2084fafc (diff)
downloadgentoo-94996ce62b0327bd8194f65d2ab9900fd78ed88e.tar.gz
gentoo-94996ce62b0327bd8194f65d2ab9900fd78ed88e.tar.xz
app-emulation/kompose: Version bump to 1.5.0
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kompose/Manifest3
-rw-r--r--app-emulation/kompose/kompose-1.5.0.ebuild30
2 files changed, 32 insertions, 1 deletions
diff --git a/app-emulation/kompose/Manifest b/app-emulation/kompose/Manifest
index a199707af8d..c2323a2a534 100644
--- a/app-emulation/kompose/Manifest
+++ b/app-emulation/kompose/Manifest
@@ -1,2 +1,3 @@
-DIST kompose-1.3.0.tar.gz 5166961 SHA256 c047708123b769d23cd8e68063b01b6229c5e76338ec294ba0e62a4b73ef46d8 SHA512 394cc35022d6c9f3e70cc8ff567f403fad84b54c71a0c7da856313162bf41223d7dff59abff372f7726404dec04283deb5e0c0960f966471f86607140eddb4d4 WHIRLPOOL e0300c3380e058351f6029ca158c1b8ba5a5c91fd5583dbad84dea7faff2f8f472fcb50eda9673d58c1711c7607d4abb2353fd957c18f4ffa4a5f90413a2c704
+DIST kompose-1.3.0.tar.gz 5166961 BLAKE2B e0ca1645ada0f423b01611e7c2b204b18b3b24d4709eea1ffc5e1092570c5ca3d3c609af5aa157a88fb987f65133be768e2965f272c23be6bc648bb3f62885ec SHA512 394cc35022d6c9f3e70cc8ff567f403fad84b54c71a0c7da856313162bf41223d7dff59abff372f7726404dec04283deb5e0c0960f966471f86607140eddb4d4
DIST kompose-1.4.0.tar.gz 5183071 SHA256 29ea870886bac78850a6b7a864ece63b3f67ed769358193d5ea12c8b0d197f82 SHA512 49d18e0c82d6195752e786d71ec67a388e6c64244dbc0376a7a41b1d31791a833d7a392c19487129d4047d102f1ec423d1531b0626003958c3375f2a0bf22686 WHIRLPOOL 81bbe1ac7f9834dd62d15c6e21acbcf6aa0d057b25906224d954c4db1cb0e3cd2313f5d1c3c08673c70bdbd9a97d9a5c6c8bedb9fbfd717a91b68bd56639f762
+DIST kompose-1.5.0.tar.gz 5184512 BLAKE2B e9b1f7d778e0128add41218c5cef8dc4e0272e85d1345948b73c3529ff6d7e17b05e8a821812e3a5f12f076d5c6c0411fa50be86ebaac54a300b263f705d10a1 SHA512 2b366ed84b5368ab8c8921a989462931edf8f4fe751e3f0ee18f1d6fd6f5bce1534e962e92d7c0d3474ed1c87f8c40b8e2e4eb1d63892ac84a41be79e527a6a1
diff --git a/app-emulation/kompose/kompose-1.5.0.ebuild b/app-emulation/kompose/kompose-1.5.0.ebuild
new file mode 100644
index 00000000000..9c0e44646e8
--- /dev/null
+++ b/app-emulation/kompose/kompose-1.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/kubernetes/kompose"
+EGIT_COMMIT="v${PV}"
+KOMPOSE_COMMIT="999278f"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Tool to move from docker-compose to Kubernetes"
+HOMEPAGE="https://github.com/kubernetes/kompose https://kompose.io"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+RESTRICT="test"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ GOPATH="${S}" go build -v -ldflags="-X github.com/kubernetes/kompose/cmd.GITCOMMIT=${COMPOSE_KOMMIT}" -o bin/kompose src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{docs,{README,RELEASE,ROADMAP,CHANGELOG,CONTRIBUTING}.md}
+}