summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-12-01 15:16:09 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-12-01 15:16:09 +0100
commita64414b3fd582f8a8e62139e79ec9addb9ee21d8 (patch)
treef92a97417bc933d181f28525a2e0b3822d4ef298 /app-emulation
parentb8712262e3ccbae71ff63bc084140aa8ad22dd03 (diff)
downloadgentoo-a64414b3fd582f8a8e62139e79ec9addb9ee21d8.tar.gz
gentoo-a64414b3fd582f8a8e62139e79ec9addb9ee21d8.tar.xz
app-emulation/containerd: Version bump to 1.0.0_rc0
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-1.0.0_rc0.ebuild52
-rw-r--r--app-emulation/containerd/metadata.xml3
3 files changed, 56 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index d13366f20d4..b153b52a643 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -2,3 +2,4 @@ DIST containerd-0.2.9_p20170605.tar.gz 1229549 SHA256 c506121c49e3bfea27018aa77e
DIST containerd-0.2.9_p20170917.tar.gz 1140788 BLAKE2B 96effa85f9cb03c3e416d53438376af6c7965660bf9c9931fdfa7fee94cca9386f2732e70dc88ee32b83e902b7d4a3072e22a817d9970ed1e07dc1271e8b33ab SHA512 c749bda691197ec8a7603db9ad92f2800a3f065143430a660333b7862518deb4c158a1c1fd01671dff438b40988d4a64d8f06bab05496b8728c6e2f57cd7da0a
DIST containerd-1.0.0_beta2_p20171019.tar.gz 3682585 BLAKE2B a67b581e3e5ddf2e95d551a9cca3dafa14772dc6ec1f1b1226ce21b0d7f88f3f80669b21f471fede50d5dd68d3916ef8696d0551c333c57e87a8ee2db3d25488 SHA512 290dcc97c47dccc6af424f5bcdfa2b59ae29eda135f71fb68a456245017a7ce5262150088f91b9edcaa19886d8919e5b6246f2816d6947c0a9b33ec6b58185e9
DIST containerd-1.0.0_beta3.tar.gz 3696070 SHA256 efd40a7fdcb07b23273c389453559c0521c2cf4baf669cdf134cd10a21627ee4 SHA512 45853001bcf57f7289747b71215eb0bc60b18e54db73896779f294db1b72374cf36c8792371a8d46ddfe283dfc9655f10cb61b3a74420a79a4abb9fa89b76323 WHIRLPOOL 63c47a18c4d5f09043d0449a042c453451bfe4fedcb1e22eb35080c3730b1f181fcb58131f58ecf8e819688ccdfd9dbe4fb70cb9f3d08782257bb6126f05e0c5
+DIST containerd-1.0.0_rc0.tar.gz 3757536 BLAKE2B f316f74ddbf6f5049e9124de47a6f988cefed6428080b3ba9939da1deb3f6146ce4d9c337b7b6f5931901390e34e8eca47b7070d4812dc4edc5bc6e280cfd777 SHA512 32d9a115214b15e10782abc8ef37115979ca49a0bbf38278c280dcb0822761f38178826f934fb034263e7e0ee07be7558b59c26276edf37294e908f4e51e3807
diff --git a/app-emulation/containerd/containerd-1.0.0_rc0.ebuild b/app-emulation/containerd/containerd-1.0.0_rc0.ebuild
new file mode 100644
index 00000000000..5b020eaa7ee
--- /dev/null
+++ b/app-emulation/containerd/containerd-1.0.0_rc0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/containerd/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_rc/-rc.}"
+ EGIT_COMMIT="v${MY_PV}"
+ CONTAINERD_COMMIT="08f1793"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+btrfs hardened"
+
+DEPEND="btrfs? ( sys-fs/btrfs-progs )"
+RDEPEND="|| ( >=app-emulation/docker-runc-1.0.0_rc4
+ >=app-emulation/runc-1.0.0_rc4 )
+ sys-libs/libseccomp"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+src_prepare() {
+ default
+ if [[ ${PV} != *9999* ]]; then
+ sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+ -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+ -e "s/-s -w//" \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ local options=( $(usex btrfs "" "no_btrfs") )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd{-shim,-stress,} bin/ctr
+}
diff --git a/app-emulation/containerd/metadata.xml b/app-emulation/containerd/metadata.xml
index 92b6d2585af..7cc46305346 100644
--- a/app-emulation/containerd/metadata.xml
+++ b/app-emulation/containerd/metadata.xml
@@ -20,6 +20,9 @@
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
</maintainer>
+ <use>
+ <flag name="btrfs">Support for BTRFS snapshot driver</flag>
+ </use>
<upstream>
<remote-id type="github">docker/containerd</remote-id>
</upstream>