summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-python
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-01-30 12:32:48 +0100
committerMichał Górny <mgorny@gentoo.org>2016-02-06 10:57:35 +0100
commit1da06d27b3cf22ad067478e8f23c15f571804e17 (patch)
tree4674561d9ffa764526b7741165263e216eff6dcc /app-eselect/eselect-python
parent8bea0d57f8e47a532b7d1ccc22296e61573dc66a (diff)
downloadgentoo-1da06d27b3cf22ad067478e8f23c15f571804e17.tar.gz
gentoo-1da06d27b3cf22ad067478e8f23c15f571804e17.tar.xz
app-eselect/eselect-python: Updated for wrappers' move to python-exec
Diffstat (limited to 'app-eselect/eselect-python')
-rw-r--r--app-eselect/eselect-python/eselect-python-99999999.ebuild45
1 files changed, 4 insertions, 41 deletions
diff --git a/app-eselect/eselect-python/eselect-python-99999999.ebuild b/app-eselect/eselect-python/eselect-python-99999999.ebuild
index 4e6988aec65..53ed376fb1c 100644
--- a/app-eselect/eselect-python/eselect-python-99999999.ebuild
+++ b/app-eselect/eselect-python/eselect-python-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -20,11 +20,7 @@ SLOT="0"
IUSE=""
RDEPEND=">=app-admin/eselect-1.2.3
- >=dev-lang/python-exec-2.1:2
- !<dev-lang/python-2.7.10-r4:2.7
- !<dev-lang/python-3.3.5-r4:3.3
- !<dev-lang/python-3.4.3-r4:3.4
- !<dev-lang/python-3.5.0-r3:3.5"
+ >=dev-lang/python-exec-2.3"
src_prepare() {
[[ ${PV} == "99999999" ]] && eautoreconf
@@ -32,36 +28,7 @@ src_prepare() {
src_install() {
keepdir /etc/env.d/python
- emake DESTDIR="${D}" install || die
-
- local f
- for f in python{,2,3}; do
- # can't use symlinks here since random stuff
- # loves to do readlink on sys.executable...
- newbin "${EPREFIX}/usr/lib/python-exec/python-exec2" "${f}"
- done
- for f in python{,2,3}-config 2to3 idle pydoc pyvenv; do
- dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
- done
-}
-
-pkg_preinst() {
- local py
-
- # Copy python[23] selection from the old format (symlink)
- for py in 2 3; do
- # default to none
- declare -g "PREV_PYTHON${py}"=
-
- if [[ -L ${EROOT}/usr/bin/python${py} ]]; then
- local target=$(readlink "${EROOT}/usr/bin/python${py}")
-
- # check if it's actually old eselect symlink
- if [[ ${target} == python?.? ]]; then
- declare -g "PREV_PYTHON${py}=${target}"
- fi
- fi
- done
+ emake DESTDIR="${D}" install
}
pkg_postinst() {
@@ -72,11 +39,7 @@ pkg_postinst() {
fi
for py in 2 3; do
- local pyvar=PREV_PYTHON${py}
- if [[ -n ${!pyvar} ]]; then
- einfo "Setting Python${py} to ${!pyvar}"
- eselect python set "--python${py}" "${!pyvar}"
- elif has_version "=dev-lang/python-${py}*"; then
+ if has_version "=dev-lang/python-${py}*"; then
eselect python update "--python${py}" --if-unset
fi
done