summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-renpy
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-eselect/eselect-renpy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-eselect/eselect-renpy')
-rw-r--r--app-eselect/eselect-renpy/eselect-renpy-0.1.ebuild39
-rw-r--r--app-eselect/eselect-renpy/eselect-renpy-0.2.ebuild39
-rw-r--r--app-eselect/eselect-renpy/eselect-renpy-0.3.ebuild39
-rw-r--r--app-eselect/eselect-renpy/eselect-renpy-0.4.ebuild39
-rw-r--r--app-eselect/eselect-renpy/eselect-renpy-0.5.ebuild39
-rw-r--r--app-eselect/eselect-renpy/files/renpy.eselect-0.115
-rw-r--r--app-eselect/eselect-renpy/files/renpy.eselect-0.215
-rw-r--r--app-eselect/eselect-renpy/files/renpy.eselect-0.315
-rw-r--r--app-eselect/eselect-renpy/files/renpy.eselect-0.415
-rw-r--r--app-eselect/eselect-renpy/files/renpy.eselect-0.515
-rw-r--r--app-eselect/eselect-renpy/metadata.xml10
11 files changed, 280 insertions, 0 deletions
diff --git a/app-eselect/eselect-renpy/eselect-renpy-0.1.ebuild b/app-eselect/eselect-renpy/eselect-renpy-0.1.ebuild
new file mode 100644
index 00000000000..e2551467fe8
--- /dev/null
+++ b/app-eselect/eselect-renpy/eselect-renpy-0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="Manages renpy symlink"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-eselect/eselect-lib-bin-symlink"
+
+S=${WORKDIR}
+
+pkg_setup() { :; }
+
+src_prepare() {
+ sed \
+ -e "s#@GAMES_BINDIR@#${GAMES_BINDIR}#" \
+ "${FILESDIR}"/renpy.eselect-${PV} > "${WORKDIR}"/renpy.eselect || die
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins renpy.eselect
+}
+
+pkg_preinst() { :; }
+
+pkg_postinst() { :; }
diff --git a/app-eselect/eselect-renpy/eselect-renpy-0.2.ebuild b/app-eselect/eselect-renpy/eselect-renpy-0.2.ebuild
new file mode 100644
index 00000000000..9ef49b449d4
--- /dev/null
+++ b/app-eselect/eselect-renpy/eselect-renpy-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="Manages renpy symlink"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="app-eselect/eselect-lib-bin-symlink"
+
+S=${WORKDIR}
+
+pkg_setup() { :; }
+
+src_prepare() {
+ sed \
+ -e "s#@GAMES_BINDIR@#${GAMES_BINDIR}#" \
+ "${FILESDIR}"/renpy.eselect-${PV} > "${WORKDIR}"/renpy.eselect || die
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins renpy.eselect
+}
+
+pkg_preinst() { :; }
+
+pkg_postinst() { :; }
diff --git a/app-eselect/eselect-renpy/eselect-renpy-0.3.ebuild b/app-eselect/eselect-renpy/eselect-renpy-0.3.ebuild
new file mode 100644
index 00000000000..9ef49b449d4
--- /dev/null
+++ b/app-eselect/eselect-renpy/eselect-renpy-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="Manages renpy symlink"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="app-eselect/eselect-lib-bin-symlink"
+
+S=${WORKDIR}
+
+pkg_setup() { :; }
+
+src_prepare() {
+ sed \
+ -e "s#@GAMES_BINDIR@#${GAMES_BINDIR}#" \
+ "${FILESDIR}"/renpy.eselect-${PV} > "${WORKDIR}"/renpy.eselect || die
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins renpy.eselect
+}
+
+pkg_preinst() { :; }
+
+pkg_postinst() { :; }
diff --git a/app-eselect/eselect-renpy/eselect-renpy-0.4.ebuild b/app-eselect/eselect-renpy/eselect-renpy-0.4.ebuild
new file mode 100644
index 00000000000..9ef49b449d4
--- /dev/null
+++ b/app-eselect/eselect-renpy/eselect-renpy-0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="Manages renpy symlink"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="app-eselect/eselect-lib-bin-symlink"
+
+S=${WORKDIR}
+
+pkg_setup() { :; }
+
+src_prepare() {
+ sed \
+ -e "s#@GAMES_BINDIR@#${GAMES_BINDIR}#" \
+ "${FILESDIR}"/renpy.eselect-${PV} > "${WORKDIR}"/renpy.eselect || die
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins renpy.eselect
+}
+
+pkg_preinst() { :; }
+
+pkg_postinst() { :; }
diff --git a/app-eselect/eselect-renpy/eselect-renpy-0.5.ebuild b/app-eselect/eselect-renpy/eselect-renpy-0.5.ebuild
new file mode 100644
index 00000000000..e2551467fe8
--- /dev/null
+++ b/app-eselect/eselect-renpy/eselect-renpy-0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="Manages renpy symlink"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-eselect/eselect-lib-bin-symlink"
+
+S=${WORKDIR}
+
+pkg_setup() { :; }
+
+src_prepare() {
+ sed \
+ -e "s#@GAMES_BINDIR@#${GAMES_BINDIR}#" \
+ "${FILESDIR}"/renpy.eselect-${PV} > "${WORKDIR}"/renpy.eselect || die
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins renpy.eselect
+}
+
+pkg_preinst() { :; }
+
+pkg_postinst() { :; }
diff --git a/app-eselect/eselect-renpy/files/renpy.eselect-0.1 b/app-eselect/eselect-renpy/files/renpy.eselect-0.1
new file mode 100644
index 00000000000..dcd203a88ff
--- /dev/null
+++ b/app-eselect/eselect-renpy/files/renpy.eselect-0.1
@@ -0,0 +1,15 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Manage default renpy version"
+MAINTAINER="hasufell@gentoo.org"
+VERSION="0.1"
+
+SYMLINK_PATH="@GAMES_BINDIR@/renpy"
+SYMLINK_TARGETS=( renpy-6.14 )
+SYMLINK_DESCRIPTION='default renpy'
+SYMLINK_CRUCIAL=1
+
+inherit bin-symlink
+
diff --git a/app-eselect/eselect-renpy/files/renpy.eselect-0.2 b/app-eselect/eselect-renpy/files/renpy.eselect-0.2
new file mode 100644
index 00000000000..e304279e0e3
--- /dev/null
+++ b/app-eselect/eselect-renpy/files/renpy.eselect-0.2
@@ -0,0 +1,15 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Manage default renpy version"
+MAINTAINER="hasufell@gentoo.org"
+VERSION="0.2"
+
+SYMLINK_PATH="@GAMES_BINDIR@/renpy"
+SYMLINK_TARGETS=( renpy-6.14 renpy-6.15 )
+SYMLINK_DESCRIPTION='default renpy'
+SYMLINK_CRUCIAL=1
+
+inherit bin-symlink
+
diff --git a/app-eselect/eselect-renpy/files/renpy.eselect-0.3 b/app-eselect/eselect-renpy/files/renpy.eselect-0.3
new file mode 100644
index 00000000000..b496e3149fd
--- /dev/null
+++ b/app-eselect/eselect-renpy/files/renpy.eselect-0.3
@@ -0,0 +1,15 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Manage default renpy version"
+MAINTAINER="hasufell@gentoo.org"
+VERSION="0.3"
+
+SYMLINK_PATH="@GAMES_BINDIR@/renpy"
+SYMLINK_TARGETS=( renpy-6.14 renpy-6.15 renpy-6.16 )
+SYMLINK_DESCRIPTION='default renpy'
+SYMLINK_CRUCIAL=1
+
+inherit bin-symlink
+
diff --git a/app-eselect/eselect-renpy/files/renpy.eselect-0.4 b/app-eselect/eselect-renpy/files/renpy.eselect-0.4
new file mode 100644
index 00000000000..1c7f45215c3
--- /dev/null
+++ b/app-eselect/eselect-renpy/files/renpy.eselect-0.4
@@ -0,0 +1,15 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Manage default renpy version"
+MAINTAINER="hasufell@gentoo.org"
+VERSION="0.4"
+
+SYMLINK_PATH="@GAMES_BINDIR@/renpy"
+SYMLINK_TARGETS=( renpy-6.14 renpy-6.15 renpy-6.16 renpy-6.17 )
+SYMLINK_DESCRIPTION='default renpy'
+SYMLINK_CRUCIAL=1
+
+inherit bin-symlink
+
diff --git a/app-eselect/eselect-renpy/files/renpy.eselect-0.5 b/app-eselect/eselect-renpy/files/renpy.eselect-0.5
new file mode 100644
index 00000000000..fb8e3f1d961
--- /dev/null
+++ b/app-eselect/eselect-renpy/files/renpy.eselect-0.5
@@ -0,0 +1,15 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Manage default renpy version"
+MAINTAINER="hasufell@gentoo.org"
+VERSION="0.5"
+
+SYMLINK_PATH="@GAMES_BINDIR@/renpy"
+SYMLINK_TARGETS=( renpy-6.14 renpy-6.15 renpy-6.16 renpy-6.17 renpy-6.18 )
+SYMLINK_DESCRIPTION='default renpy'
+SYMLINK_CRUCIAL=1
+
+inherit bin-symlink
+
diff --git a/app-eselect/eselect-renpy/metadata.xml b/app-eselect/eselect-renpy/metadata.xml
new file mode 100644
index 00000000000..e52db06ebd8
--- /dev/null
+++ b/app-eselect/eselect-renpy/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+</pkgmetadata>
+