summaryrefslogtreecommitdiff
path: root/app-eselect
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-25 13:35:51 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-25 13:37:03 +0100
commitf28f2e793b1639b91e2e47ba50886bf25d0d28d6 (patch)
treef1c164c2fa99e2a16fcdf983f0029bba4a1a08c1 /app-eselect
parentf606697478b4d340576e3c0964e30737b9f897f6 (diff)
downloadgentoo-f28f2e793b1639b91e2e47ba50886bf25d0d28d6.tar.gz
gentoo-f28f2e793b1639b91e2e47ba50886bf25d0d28d6.tar.xz
app-eselect/eselect-python: Replace python{,2,3} symlinks with files
Copy python-exec script to /usr/bin/python{,2,3} rather than symlinking it because a lot of Python scripts like to readlink(sys.executable) and don't expect to find python-exec in there...
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-python/eselect-python-20151117-r1.ebuild (renamed from app-eselect/eselect-python/eselect-python-20151117.ebuild)7
-rw-r--r--app-eselect/eselect-python/eselect-python-99999999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/app-eselect/eselect-python/eselect-python-20151117.ebuild b/app-eselect/eselect-python/eselect-python-20151117-r1.ebuild
index f78b25f806a..7fb2788fe01 100644
--- a/app-eselect/eselect-python/eselect-python-20151117.ebuild
+++ b/app-eselect/eselect-python/eselect-python-20151117-r1.ebuild
@@ -35,7 +35,12 @@ src_install() {
emake DESTDIR="${D}" install || die
local f
- for f in python{,2,3}{,-config} 2to3 pydoc pyvenv; do
+ for f in python{,2,3}; do
+ # can't use symlinks here since random stuff
+ # loves to do readlink on sys.executable...
+ newbin "${EPREFIX}/usr/lib/python-exec/python-exec2" "${f}"
+ done
+ for f in python{,2,3}-config 2to3 pydoc pyvenv; do
dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
done
}
diff --git a/app-eselect/eselect-python/eselect-python-99999999.ebuild b/app-eselect/eselect-python/eselect-python-99999999.ebuild
index f78b25f806a..7fb2788fe01 100644
--- a/app-eselect/eselect-python/eselect-python-99999999.ebuild
+++ b/app-eselect/eselect-python/eselect-python-99999999.ebuild
@@ -35,7 +35,12 @@ src_install() {
emake DESTDIR="${D}" install || die
local f
- for f in python{,2,3}{,-config} 2to3 pydoc pyvenv; do
+ for f in python{,2,3}; do
+ # can't use symlinks here since random stuff
+ # loves to do readlink on sys.executable...
+ newbin "${EPREFIX}/usr/lib/python-exec/python-exec2" "${f}"
+ done
+ for f in python{,2,3}-config 2to3 pydoc pyvenv; do
dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
done
}