summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-fbterm
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/ibus-fbterm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/ibus-fbterm')
-rw-r--r--app-i18n/ibus-fbterm/Manifest1
-rw-r--r--app-i18n/ibus-fbterm/files/ibus-fbterm-0.9.1-ibus-1.4.1.patch23
-rw-r--r--app-i18n/ibus-fbterm/files/ibus-fbterm-0.9.1-ibus-1.4.99.patch22
-rw-r--r--app-i18n/ibus-fbterm/ibus-fbterm-0.9.1.ebuild25
-rw-r--r--app-i18n/ibus-fbterm/metadata.xml5
5 files changed, 76 insertions, 0 deletions
diff --git a/app-i18n/ibus-fbterm/Manifest b/app-i18n/ibus-fbterm/Manifest
new file mode 100644
index 00000000000..6329759cca9
--- /dev/null
+++ b/app-i18n/ibus-fbterm/Manifest
@@ -0,0 +1 @@
+DIST ibus-fbterm-0.9.1.tar.gz 106808 SHA256 98437db4d5d15bbdca3e4b0a08f1bd1be544a305aa1d0f65fedb81b871da2e7c SHA512 7f5bbb0ebf5ad12f3bdccb7966cb1ff7f40f8ebfb94a5767e0382ef5eee24f22021a428ac8073e987c43f32d67cfb7922ffe63666d88dcbd56cfdbcd36f3156f WHIRLPOOL 110e38beadfd64e75b6a40b9885b8aa1dec30771aeaff5dcd4c0f7403d24faa63b6a72d6a3fe79ec3fc1eb09e0f5963dee85664d41849ce3d723e4996ef6ebff
diff --git a/app-i18n/ibus-fbterm/files/ibus-fbterm-0.9.1-ibus-1.4.1.patch b/app-i18n/ibus-fbterm/files/ibus-fbterm-0.9.1-ibus-1.4.1.patch
new file mode 100644
index 00000000000..08508c23180
--- /dev/null
+++ b/app-i18n/ibus-fbterm/files/ibus-fbterm-0.9.1-ibus-1.4.1.patch
@@ -0,0 +1,23 @@
+diff -Nurap ibus-fbterm-0.9.1.orig//src/display.c ibus-fbterm-0.9.1//src/display.c
+--- ibus-fbterm-0.9.1.orig//src/display.c 2012-06-06 17:59:26.000000000 +0900
++++ ibus-fbterm-0.9.1//src/display.c 2012-06-06 18:05:22.000000000 +0900
+@@ -212,7 +212,7 @@ static void calculate_status_win()
+ IBusProperty *prop = ibus_prop_list_get(property_list, i);
+ if (!prop) break;
+
+- w += text_width(prop->label->text);
++ w += text_width(ibus_property_get_label(prop)->text);
+ }
+
+ status_bar_win.x = cursor_x;
+@@ -238,8 +238,8 @@ static void draw_status_bar()
+ IBusProperty *prop = ibus_prop_list_get(property_list, i);
+ if (!prop) break;
+
+- draw_text(x, y, COLOR_FG, COLOR_BG, prop->label->text, strlen(prop->label->text));
+- x += FW(text_width(prop->label->text));
++ draw_text(x, y, COLOR_FG, COLOR_BG, ibus_property_get_label(prop)->text, strlen(ibus_property_get_label(prop)->text));
++ x += FW(text_width(ibus_property_get_label(prop)->text));
+
+ char space = ' ';
+ draw_text(x, y, COLOR_FG, COLOR_BG, &space, 1);
diff --git a/app-i18n/ibus-fbterm/files/ibus-fbterm-0.9.1-ibus-1.4.99.patch b/app-i18n/ibus-fbterm/files/ibus-fbterm-0.9.1-ibus-1.4.99.patch
new file mode 100644
index 00000000000..6cf85865904
--- /dev/null
+++ b/app-i18n/ibus-fbterm/files/ibus-fbterm-0.9.1-ibus-1.4.99.patch
@@ -0,0 +1,22 @@
+diff --git a/src/ibus-fbterm.c b/src/ibus-fbterm.c
+index ffb7401..b4ddb64 100644
+--- a/src/ibus-fbterm.c
++++ b/src/ibus-fbterm.c
+@@ -119,13 +119,17 @@ static void im_active()
+ debug("im active\n");
+ modifier_state = 0;
+ init_keycode_state();
++#if ! IBUS_CHECK_VERSION(1, 4, 99)
+ ibus_input_context_enable(ibus_ctx);
++#endif
+ }
+
+ static void im_deactive()
+ {
+ debug("im deactive\n");
++#if ! IBUS_CHECK_VERSION(1, 4, 99)
+ ibus_input_context_disable(ibus_ctx);
++#endif
+
+ auxiliary_text_win.w = 0;
+ lookup_table_win.w = 0;
diff --git a/app-i18n/ibus-fbterm/ibus-fbterm-0.9.1.ebuild b/app-i18n/ibus-fbterm/ibus-fbterm-0.9.1.ebuild
new file mode 100644
index 00000000000..53fedfcf7e8
--- /dev/null
+++ b/app-i18n/ibus-fbterm/ibus-fbterm-0.9.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+inherit autotools-utils
+
+DESCRIPTION="ibus-fbterm is a input method for FbTerm based on iBus"
+HOMEPAGE="http://ibus-fbterm.googlecode.com"
+SRC_URI="https://ibus-fbterm.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/ibus-1.4.1
+ app-i18n/fbterm"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ibus-1.4.1.patch
+ "${FILESDIR}"/${P}-ibus-1.4.99.patch
+)
diff --git a/app-i18n/ibus-fbterm/metadata.xml b/app-i18n/ibus-fbterm/metadata.xml
new file mode 100644
index 00000000000..2d5852c16c6
--- /dev/null
+++ b/app-i18n/ibus-fbterm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+</pkgmetadata>