summaryrefslogtreecommitdiff
path: root/app-i18n/opencc
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2018-10-10 02:56:23 +0900
committerNaohiro Aota <naota@gentoo.org>2018-10-10 02:57:31 +0900
commit50be00f6ee1ce7eaa585389586a5d838e65e647b (patch)
tree2ed4aa43b6ffad6d0a821075ddc88574e2c51269 /app-i18n/opencc
parentb128d56fed349c13bdbf670b4cfe9c4e56b3284f (diff)
downloadgentoo-50be00f6ee1ce7eaa585389586a5d838e65e647b.tar.gz
gentoo-50be00f6ee1ce7eaa585389586a5d838e65e647b.tar.xz
app-i18n/opencc: add patch to avoid conflicting copy
copy command is only necessary in VS build, and it's causing conflict on parallel build. Dropping the command is safe on Linux. Closes: https://bugs.gentoo.org/666904 Signed-off-by: Naohiro Aota <naota@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'app-i18n/opencc')
-rw-r--r--app-i18n/opencc/files/opencc-stop-copy.patch18
-rw-r--r--app-i18n/opencc/opencc-1.0.5.ebuild7
-rw-r--r--app-i18n/opencc/opencc-9999.ebuild7
3 files changed, 28 insertions, 4 deletions
diff --git a/app-i18n/opencc/files/opencc-stop-copy.patch b/app-i18n/opencc/files/opencc-stop-copy.patch
new file mode 100644
index 00000000000..4793951dd25
--- /dev/null
+++ b/app-i18n/opencc/files/opencc-stop-copy.patch
@@ -0,0 +1,18 @@
+We don't need this copy command on Linux (or other than Visual Studio
+build). Since it is colliding each other on parallel build, drop the
+command for now.
+
+See https://bugs.gentoo.org/666904
+diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
+index 1516775..2deb764 100644
+--- a/data/CMakeLists.txt
++++ b/data/CMakeLists.txt
+@@ -109,8 +109,6 @@ foreach(DICT ${DICTS})
+ ${DICT}.ocd
+ COMMENT
+ "Building ${DICT}.ocd"
+- COMMAND
+- ${CMAKE_COMMAND} -E copy "$<TARGET_FILE:libopencc>" "$<TARGET_FILE_DIR:${OPENCC_DICT_BIN}>"
+ COMMAND
+ ${OPENCC_DICT_BIN}
+ --input ${DICT_${DICT}_INPUT}
diff --git a/app-i18n/opencc/opencc-1.0.5.ebuild b/app-i18n/opencc/opencc-1.0.5.ebuild
index ba948e2bf80..2ddcaab943f 100644
--- a/app-i18n/opencc/opencc-1.0.5.ebuild
+++ b/app-i18n/opencc/opencc-1.0.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -26,7 +26,10 @@ IUSE="doc test"
DEPEND="doc? ( app-doc/doxygen )"
DOCS="AUTHORS *.md"
-PATCHES=( "${FILESDIR}"/${PN}-test.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-test.patch
+ "${FILESDIR}"/${PN}-stop-copy.patch
+)
src_prepare() {
sed -i "s|\${DIR_SHARE_OPENCC}/doc|share/doc/${PF}|" doc/CMakeLists.txt
diff --git a/app-i18n/opencc/opencc-9999.ebuild b/app-i18n/opencc/opencc-9999.ebuild
index 9ec1cbd5d8b..857d6dd70b8 100644
--- a/app-i18n/opencc/opencc-9999.ebuild
+++ b/app-i18n/opencc/opencc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -26,7 +26,10 @@ IUSE="doc test"
DEPEND="doc? ( app-doc/doxygen )"
DOCS="AUTHORS *.md"
-PATCHES=( "${FILESDIR}"/${PN}-test.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-test.patch
+ "${FILESDIR}"/${PN}-stop-copy.patch
+)
src_prepare() {
sed -i "s|\${DIR_SHARE_OPENCC}/doc|share/doc/${PF}|" doc/CMakeLists.txt