summaryrefslogtreecommitdiff
path: root/app-i18n/opencc
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/opencc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/opencc')
-rw-r--r--app-i18n/opencc/Manifest3
-rw-r--r--app-i18n/opencc/files/opencc-0.3.0_pre20120819-cmake-libdir.patch17
-rw-r--r--app-i18n/opencc/metadata.xml10
-rw-r--r--app-i18n/opencc/opencc-0.2.0.ebuild41
-rw-r--r--app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild42
-rw-r--r--app-i18n/opencc/opencc-0.3.0_pre20120819.ebuild41
-rw-r--r--app-i18n/opencc/opencc-0.4.3.ebuild36
7 files changed, 190 insertions, 0 deletions
diff --git a/app-i18n/opencc/Manifest b/app-i18n/opencc/Manifest
new file mode 100644
index 00000000000..d427f14a127
--- /dev/null
+++ b/app-i18n/opencc/Manifest
@@ -0,0 +1,3 @@
+DIST opencc-0.2.0.tar.gz 496313 SHA256 fc4b3203482c7e5ad5c887dc08f83cd1d0e0c1fd1bdd9ec48672ca89bfe2a424 SHA512 46c03a1605b8c464d8836bfa6e69fef1d1978102aa6a75ab75c9546635da91223bb26412639869a1f7fc3f8db1f4ebd12645c53d07cb1375605dbb42c7e4524a WHIRLPOOL 98675c15579e573633f68e9c73a83164a3bd0ebb82b7b92dd31dfddda4a6cd3c81dd4cbd5fd775021b29e7c543952bf2206c2c00257fdc11f91754f56a969e9b
+DIST opencc-0.3.0_pre20120819.tar.xz 363528 SHA256 3ed46594547b86f1326b07c3ea910148b1c58b74c9d21c8d4e11ec30e2254fae SHA512 0ca231b5fd7b314111a76bfaa8e288fc2d43e02dbbb2a7c7e9312c1f1f0aed1a0d3b67b04b0cc3634d1b48b8fe6983e6219db053f3a2114abadec1af00b9f8d5 WHIRLPOOL 268d331479bffefdc6e1f58600422a36a32abb7d4dd873eeb216977daca05f4a4775ca547bb301bc16ea8fc702ef04cfd5d8f88c90d10e224a585575129e67c6
+DIST opencc-0.4.3.tar.gz 535151 SHA256 7bdcf9e38ac05a16750d5276494d810db107c8a8b5f8b87e2357ee167a13a587 SHA512 ac31c3c018467cf047e077d399903560feb0f8c214accd1ef45d0b1477d011af8e9bf2dbde4497c133daef61b6508460e9b2b04c0b5f336c2d67fc840a1d07e6 WHIRLPOOL 316857e7720e962c9fde27c04327c0c6b5137ca7290b170cc1ead86dcd0c6f14202ac2386f6e565ad12ebca99c939a511447902054792203edeabed88e149a2e
diff --git a/app-i18n/opencc/files/opencc-0.3.0_pre20120819-cmake-libdir.patch b/app-i18n/opencc/files/opencc-0.3.0_pre20120819-cmake-libdir.patch
new file mode 100644
index 00000000000..76dc4330c44
--- /dev/null
+++ b/app-i18n/opencc/files/opencc-0.3.0_pre20120819-cmake-libdir.patch
@@ -0,0 +1,17 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -70,11 +70,11 @@ set (DIR_SHARE ${DIR_PREFIX}/share)
+ set (DIR_BIN ${DIR_PREFIX}/bin)
+ set (DIR_ETC ${DIR_PREFIX}/etc)
+
+ if (DEFINED CMAKE_INSTALL_LIBDIR)
+- set (DIR_LIBRARY ${CMAKE_INSTALL_LIBDIR})
+- set (DIR_LIBRARY_STATIC ${CMAKE_INSTALL_LIBDIR})
++ set (DIR_LIBRARY ${DIR_PREFIX}/${CMAKE_INSTALL_LIBDIR})
++ set (DIR_LIBRARY_STATIC ${DIR_PREFIX}/${CMAKE_INSTALL_LIBDIR})
+ endif (DEFINED CMAKE_INSTALL_LIBDIR)
+
+ if (DEFINED SHARE_INSTALL_PREFIX)
+ set (DIR_SHARE ${SHARE_INSTALL_PREFIX})
+ endif (DEFINED SHARE_INSTALL_PREFIX)
diff --git a/app-i18n/opencc/metadata.xml b/app-i18n/opencc/metadata.xml
new file mode 100644
index 00000000000..e60b8b7f6ef
--- /dev/null
+++ b/app-i18n/opencc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <longdescription lang="en">OpenCC is a library for converting characters and phrases between
+Traditional Chinese and Simplified Chinese.</longdescription>
+ <upstream>
+ <remote-id type="google-code">open-chinese-convert</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-i18n/opencc/opencc-0.2.0.ebuild b/app-i18n/opencc/opencc-0.2.0.ebuild
new file mode 100644
index 00000000000..a219a653a14
--- /dev/null
+++ b/app-i18n/opencc/opencc-0.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils multilib
+
+DESCRIPTION="Libraries for Simplified-Traditional Chinese Conversion"
+HOMEPAGE="http://code.google.com/p/open-chinese-convert/"
+SRC_URI="http://open-chinese-convert.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS="AUTHORS ChangeLog README"
+
+src_prepare() {
+ sed -i \
+ -e "s:\${CMAKE_\(SHARED\|STATIC\)_LIBRARY_PREFIX}:\"$(get_libdir)\":" \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use_enable nls GETTEXT)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use static-libs || find "${ED}" -name '*.la' -o -name '*.a' -exec rm {} +
+}
diff --git a/app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild b/app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild
new file mode 100644
index 00000000000..5b8ebe6b609
--- /dev/null
+++ b/app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils multilib eutils
+
+DESCRIPTION="Libraries for Simplified-Traditional Chinese Conversion"
+HOMEPAGE="http://code.google.com/p/open-chinese-convert/"
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86"
+IUSE="+nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS="AUTHORS README"
+
+src_prepare() {
+ sed -i \
+ -e "s:\${CMAKE_\(SHARED\|STATIC\)_LIBRARY_PREFIX}:\"$(get_libdir)\":" \
+ CMakeLists.txt || die
+ epatch "${FILESDIR}"/${P}-cmake-libdir.patch
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use_enable nls GETTEXT)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use static-libs || find "${ED}" -name '*.la' -o -name '*.a' -exec rm {} +
+}
diff --git a/app-i18n/opencc/opencc-0.3.0_pre20120819.ebuild b/app-i18n/opencc/opencc-0.3.0_pre20120819.ebuild
new file mode 100644
index 00000000000..bcea0163b1a
--- /dev/null
+++ b/app-i18n/opencc/opencc-0.3.0_pre20120819.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils multilib
+
+DESCRIPTION="Libraries for Simplified-Traditional Chinese Conversion"
+HOMEPAGE="http://code.google.com/p/open-chinese-convert/"
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE="+nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS="AUTHORS README"
+
+src_prepare() {
+ sed -i \
+ -e "s:\${CMAKE_\(SHARED\|STATIC\)_LIBRARY_PREFIX}:\"$(get_libdir)\":" \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use_enable nls GETTEXT)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use static-libs || find "${ED}" -name '*.la' -o -name '*.a' -exec rm {} +
+}
diff --git a/app-i18n/opencc/opencc-0.4.3.ebuild b/app-i18n/opencc/opencc-0.4.3.ebuild
new file mode 100644
index 00000000000..26fb8a347a0
--- /dev/null
+++ b/app-i18n/opencc/opencc-0.4.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils multilib eutils
+
+DESCRIPTION="Libraries for conversion between Traditional and Simplified Chinese"
+HOMEPAGE="http://code.google.com/p/opencc/"
+SRC_URI="https://opencc.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="+nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS="AUTHORS NEWS.md README.md"
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use_enable nls GETTEXT)"
+ -DCMAKE_INSTALL_LIBDIR="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use static-libs || find "${ED}" -name '*.la' -o -name '*.a' -exec rm {} +
+}