summaryrefslogtreecommitdiff
path: root/app-i18n/scim-tomoe
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/scim-tomoe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/scim-tomoe')
-rw-r--r--app-i18n/scim-tomoe/Manifest1
-rw-r--r--app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gcc43.patch11
-rw-r--r--app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gucharmap2.patch21
-rw-r--r--app-i18n/scim-tomoe/metadata.xml11
-rw-r--r--app-i18n/scim-tomoe/scim-tomoe-0.6.0-r1.ebuild29
-rw-r--r--app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild38
-rw-r--r--app-i18n/scim-tomoe/scim-tomoe-0.6.0.ebuild23
7 files changed, 134 insertions, 0 deletions
diff --git a/app-i18n/scim-tomoe/Manifest b/app-i18n/scim-tomoe/Manifest
new file mode 100644
index 00000000000..9258abca769
--- /dev/null
+++ b/app-i18n/scim-tomoe/Manifest
@@ -0,0 +1 @@
+DIST scim-tomoe-0.6.0.tar.gz 385126 SHA256 4f053944285ed50e7916ebdb38298025e60eb430b64715fdad9375483456dc06 SHA512 d70a8838f8c82c76a8e3592ad712997189873cbc4ec7ebeba5d43d6583e24acf318299433c9342ee004c4ae4741cca7e0b88e4642cf46c43f967a47ec5ac9d4f WHIRLPOOL 4d34f4618efa12802fce12da42276d5b2a92dcc0ad591c337f6f8a28b5441c2db5639b07ec9aae6262a0b0ed74f460b9530748b229bcf529f30a1e2a038cb685
diff --git a/app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gcc43.patch b/app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gcc43.patch
new file mode 100644
index 00000000000..5464debb019
--- /dev/null
+++ b/app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gcc43.patch
@@ -0,0 +1,11 @@
+diff -Naur scim-tomoe-0.6.0.orig/src/scim_tomoe_prefs_widget.cpp scim-tomoe-0.6.0/src/scim_tomoe_prefs_widget.cpp
+--- scim-tomoe-0.6.0.orig/src/scim_tomoe_prefs_widget.cpp 2007-05-07 16:49:15.000000000 +0900
++++ scim-tomoe-0.6.0/src/scim_tomoe_prefs_widget.cpp 2008-09-24 00:57:47.000000000 +0900
+@@ -22,6 +22,7 @@
+ #endif
+
+ #include <glib/gi18n-lib.h>
++#include <cstring>
+
+ #include "scim_tomoe_prefs_widget.h"
+ #include "scim_tomoe_prefs.h"
diff --git a/app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gucharmap2.patch b/app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gucharmap2.patch
new file mode 100644
index 00000000000..0444bb2e6dd
--- /dev/null
+++ b/app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gucharmap2.patch
@@ -0,0 +1,21 @@
+---
+ Update libtomoe-gtk to gucharmap-2 API
+ https://bugs.gentoo.org/show_bug.cgi?id=243160
+
+ scim_tomoe_prefs_widget.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- a/src/scim_tomoe_prefs_widget.cpp 2008-12-06 16:40:15.000000000 +0100
++++ b/src/scim_tomoe_prefs_widget.cpp 2008-12-06 17:01:19.000000000 +0100
+@@ -473,9 +473,9 @@
+ String (SCIM_TOMOE_CONFIG_UNICODE_TABLE_FONT_DEFAULT));
+
+ if (font.length() > 0) {
+- gucharmap_charmap_set_font (charmap, font.c_str ());
++ gucharmap_charmap_set_font_desc (charmap, pango_font_description_from_string(font.c_str ()));
+ } else {
+- gucharmap_charmap_set_font (charmap, NULL);
++ gucharmap_charmap_set_font_desc (charmap, pango_font_description_from_string(NULL));
+ set_default_font (prefs, SCIM_TOMOE_CONFIG_CAND_FONT,
+ GTK_WIDGET (charmap));
+ }
diff --git a/app-i18n/scim-tomoe/metadata.xml b/app-i18n/scim-tomoe/metadata.xml
new file mode 100644
index 00000000000..084e6cd5c68
--- /dev/null
+++ b/app-i18n/scim-tomoe/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <use>
+ <flag name="gucharmap">Enable gucharmap dictionary plugin</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">tomoe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r1.ebuild b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r1.ebuild
new file mode 100644
index 00000000000..013a4fbbdc5
--- /dev/null
+++ b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Japanese input method Tomoe IMEngine for SCIM"
+HOMEPAGE="http://tomoe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=app-i18n/scim-1.2.0
+ >=app-i18n/libtomoe-gtk-0.6.0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild
new file mode 100644
index 00000000000..2831d2c6e20
--- /dev/null
+++ b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Japanese input method Tomoe IMEngine for SCIM"
+HOMEPAGE="http://tomoe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gucharmap"
+
+RDEPEND=">=app-i18n/scim-1.2.0
+ >=app-i18n/libtomoe-gtk-0.6.0[gucharmap=]
+ gucharmap? ( >=gnome-extra/gucharmap-1.4 )
+ >=x11-libs/gtk+-2.4:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35.0"
+
+src_prepare() {
+ # Fix build with gcc-4.3, bug #
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+
+ # Fix build with gucharmap-2.24, bug #243160
+ epatch "${FILESDIR}/${P}-gucharmap2.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/app-i18n/scim-tomoe/scim-tomoe-0.6.0.ebuild b/app-i18n/scim-tomoe/scim-tomoe-0.6.0.ebuild
new file mode 100644
index 00000000000..5f032b80eb0
--- /dev/null
+++ b/app-i18n/scim-tomoe/scim-tomoe-0.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Japanese input method Tomoe IMEngine for SCIM"
+HOMEPAGE="http://tomoe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND="|| ( >=app-i18n/scim-1.2.0 >=app-i18n/scim-cvs-1.2.0 )
+ >=app-i18n/libtomoe-gtk-0.6.0"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}