summaryrefslogtreecommitdiff
path: root/app-i18n/zinnia/zinnia-0.06-r3.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/zinnia/zinnia-0.06-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/zinnia/zinnia-0.06-r3.ebuild')
-rw-r--r--app-i18n/zinnia/zinnia-0.06-r3.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-i18n/zinnia/zinnia-0.06-r3.ebuild b/app-i18n/zinnia/zinnia-0.06-r3.ebuild
new file mode 100644
index 00000000000..4517a348ce4
--- /dev/null
+++ b/app-i18n/zinnia/zinnia-0.06-r3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit perl-module eutils flag-o-matic toolchain-funcs autotools-utils
+
+DESCRIPTION="Online hand recognition system with machine learning"
+HOMEPAGE="http://zinnia.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zinnia/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+# Package warrants IUSE doc
+IUSE="perl static-libs"
+DOCS=( AUTHORS ChangeLog NEWS README )
+PATCHES=(
+ "${FILESDIR}/${P}-ricedown.patch"
+ "${FILESDIR}/${P}-perl.patch"
+)
+AUTOTOOLS_AUTORECONF=yes
+
+src_prepare() {
+ autotools-utils_src_prepare
+ if use perl ; then
+ pushd "${S}/perl" >/dev/null
+ PATCHES=()
+ perl-module_src_prepare
+ popd >/dev/null
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use perl ; then
+ pushd "${S}"/perl >/dev/null
+
+ # We need to run this here as otherwise it won't pick up the
+ # just-built -lzinnia and cause the extension to have
+ # undefined symbols.
+ perl-module_src_configure
+
+ append-cppflags "-I${S}"
+ append-ldflags "-L${S}/.libs"
+
+ emake \
+ LDDLFLAGS="-shared" \
+ OTHERLDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCXX)" LD="$(tc-getCXX)" \
+ OPTIMIZE="${CPPFLAGS} ${CXXFLAGS}"
+ popd >/dev/null
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use perl ; then
+ pushd "${S}/perl" >/dev/null
+ perl-module_src_install
+ popd >/dev/null
+ fi
+
+ # Curiously ChangeLog & NEWS are left uncompressed
+ dohtml doc/*.html doc/*.css
+}