summaryrefslogtreecommitdiff
path: root/app-i18n
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-16 22:17:37 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-16 22:17:56 +0200
commit8c0906ea66ab81c026028b346b31e87358eb75ee (patch)
treea16ed8a932046bd8893183304b7cff09ba5d7bb9 /app-i18n
parent578f38a7d4bcb1c2daee0f376515be9a8334ea5f (diff)
downloadgentoo-8c0906ea66ab81c026028b346b31e87358eb75ee.tar.gz
gentoo-8c0906ea66ab81c026028b346b31e87358eb75ee.tar.xz
Revert "app-i18n/sunpinyin: Drop old, bug 605728" (is still needed)
This reverts commit a5c1b4df8e3d3c0b301334649f4f3eb5258fbe06.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/sunpinyin/Manifest3
-rw-r--r--app-i18n/sunpinyin/sunpinyin-2.0.3-r1.ebuild64
2 files changed, 67 insertions, 0 deletions
diff --git a/app-i18n/sunpinyin/Manifest b/app-i18n/sunpinyin/Manifest
index 6a7d9e8dd0d..8ea93a2261f 100644
--- a/app-i18n/sunpinyin/Manifest
+++ b/app-i18n/sunpinyin/Manifest
@@ -1 +1,4 @@
+DIST dict.utf8.tar.bz2 1598995 SHA256 d8261f6b0bfcdd40a9c4f366228f86b017e06c9d7d64d6ddec1c2c3511eea805 SHA512 04ec55e4af4b58d29b1141a824b5c3de5dbaaab0133d88e477d9183db738fc63543b4004bf071e611c6ea0d4b4c161b73849a64ab75f4df5bb5116d7f52d8e34 WHIRLPOOL c1ead1556dbcbe0811551cff2b84367ce9827a06733a3f5a6c2a229882ecd9b83069455146d6ea507d235ef3ad979cd10d373cfc806e150ad0fae9bd91330925
+DIST lm_sc.t3g.arpa.tar.bz2 25098718 SHA256 c80093a8b43561e64158de4139967eef39b851432a2660e8050429d7560907cd SHA512 1e5e577c92df2f230b6b5962298ef7c215f6069b53e8e2dd4c5ad3eb54f999fc239b0924b4ab031af59c3194da15d6317ea2860f158e805b5cf0126666eaad98 WHIRLPOOL 294b668ca6bcb765392f882bd9b0f16e403c8709eb2d7ae129e4c4aba3372b8b6d9b6a78df67b811a742136e4d1b203b5da7e7f7554296c6986a6fcba361b50b
+DIST sunpinyin-2.0.3.tar.gz 169394 SHA256 4ab776e7563f69f8dbda8fac7cfaa42bd0db1ea68bab15f756094ce5398d83d1 SHA512 25f1fc4b8f550663861f2c7426832924676f83e1f201689fde51b04ca78704b46dbbf2b92736234d5e1a729ba1bb23bd1f3a0394f6b8b54cb0df57b9bb7ece1d WHIRLPOOL 71a4efedcbe4ec1dda9ecb1b94256a0e5e8ca570a234a8b378f85af68bf3da9f3b9220aee98c2f3ce509daa33996fea8b554e81594c299281ede58167cf633e8
DIST sunpinyin-2.0.4_pre20130108.tar.xz 964764 SHA256 e650957aced55075448b7f02298d0c5cf59a8b8e041e9c7d92d24cb5170de93f SHA512 7c1dd7db8b800e9d436746a560a16de2c6777576868f2e7e28f6dcb767b91ccd62b974f9d4ce6bd6ce80d30e1ee83887c3ee03c227e7e9fa59c01db4867465b2 WHIRLPOOL 82535dcde38c2fce17877e465db7ebeaed14a7f305ad96ca451c5b35ae04244a94e9bde9ce51092a390964c557e39ab43742d2370342f9b72722b24f916c55d6
diff --git a/app-i18n/sunpinyin/sunpinyin-2.0.3-r1.ebuild b/app-i18n/sunpinyin/sunpinyin-2.0.3-r1.ebuild
new file mode 100644
index 00000000000..c0dea27daf5
--- /dev/null
+++ b/app-i18n/sunpinyin/sunpinyin-2.0.3-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+
+inherit eutils multilib scons-utils toolchain-funcs
+
+DESCRIPTION="SunPinyin is a SLM (Statistical Language Model) based IME"
+HOMEPAGE="https://sunpinyin.googlecode.com"
+SRC_URI="${HOMEPAGE}/files/${P}.tar.gz
+ https://open-gram.googlecode.com/files/dict.utf8.tar.bz2
+ https://open-gram.googlecode.com/files/lm_sc.t3g.arpa.tar.bz2"
+
+LICENSE="LGPL-2.1 CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ ln -s "${DISTDIR}/dict.utf8.tar.bz2" "${S}/raw/" || die "dict file not found"
+ ln -s "${DISTDIR}/lm_sc.t3g.arpa.tar.bz2" "${S}/raw/" || die "dict file not found"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-force-switch.patch"
+ epatch "${FILESDIR}/${P}-gcc-4.7.patch"
+}
+
+src_configure() {
+ tc-export CXX
+ myesconsargs=(
+ --prefix="${EPREFIX}"/usr
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --libdatadir="${EPREFIX}"/usr/lib
+ )
+}
+
+src_compile() {
+ escons || die
+}
+
+src_install() {
+ escons --install-sandbox="${ED}" install || die
+}
+
+pkg_postinst() {
+ elog ""
+ elog "If you have already installed former version of ${PN}"
+ elog "and any wrapper, please remerge the wrapper to make it work with"
+ elog "the new version."
+ elog ""
+ elog "To use any wrapper for ${PN}, please merge any of the following"
+ elog "packages: "
+ elog "emerge app-i18n/fcitx-sunpinyin"
+ elog "emerge app-i18n/ibus-sunpinyin"
+ elog "emerge app-i18n/scim-sunpinyin"
+ elog "emerge app-i18n/xsunpinyin"
+ elog ""
+}