summaryrefslogtreecommitdiff
path: root/app-laptop/mbpfan/mbpfan-1.9.1.ebuild
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2016-10-17 07:28:51 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2016-10-17 07:28:51 -0400
commitd22cb0baccdcdf74f6fb994c4ceae95f0bbb88f5 (patch)
tree1c0fe7bad1d93582910b5176c6e1bdbd982c86c6 /app-laptop/mbpfan/mbpfan-1.9.1.ebuild
parent000d48c2d1cbd86e2fd349a8776f56d3ca42dccf (diff)
downloadgentoo-d22cb0baccdcdf74f6fb994c4ceae95f0bbb88f5.tar.gz
gentoo-d22cb0baccdcdf74f6fb994c4ceae95f0bbb88f5.tar.xz
app-laptop/mbpfan: initial commit with versions 1.9.1 and live
mbpfan is a daemon that uses input from coretemp module and sets the fan speed using the applesmc module. This enhanced version assumes any number of processors and fans. Package-Manager: portage-2.3.0
Diffstat (limited to 'app-laptop/mbpfan/mbpfan-1.9.1.ebuild')
-rw-r--r--app-laptop/mbpfan/mbpfan-1.9.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-laptop/mbpfan/mbpfan-1.9.1.ebuild b/app-laptop/mbpfan/mbpfan-1.9.1.ebuild
new file mode 100644
index 00000000000..53c7ae432df
--- /dev/null
+++ b/app-laptop/mbpfan/mbpfan-1.9.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
+HOMEPAGE="https://github.com/dgraziotin/mbpfan"
+SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # will fail if the hardware is unavailable, not useful
+
+CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
+
+src_prepare() {
+ sed -i -e "s:g++:$(tc-getCXX):g" Makefile || die
+ default
+}
+
+src_install() {
+ dosbin bin/mbpfan
+
+ insinto /etc
+ doins ${PN}.conf
+
+ newinitd ${PN}.init.gentoo ${PN}
+ systemd_dounit ${PN}.service
+
+ einstalldocs
+}