summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-blasq/lc-blasq-9999.ebuild
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2017-02-25 19:49:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-26 12:58:56 +0100
commit09222bd0523d448c79f1434b042f55e440097adf (patch)
tree899893b57e6ed056d7eb0f4350388ccbedbc6b90 /app-leechcraft/lc-blasq/lc-blasq-9999.ebuild
parent99d36d2e957164374ebcc9fa990509dc2f81833f (diff)
downloadgentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.gz
gentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.xz
app-leechcraft: use Qt5, modernize the eclass and ebuilds
Closes: https://github.com/gentoo/gentoo/pull/4079
Diffstat (limited to 'app-leechcraft/lc-blasq/lc-blasq-9999.ebuild')
-rw-r--r--app-leechcraft/lc-blasq/lc-blasq-9999.ebuild32
1 files changed, 21 insertions, 11 deletions
diff --git a/app-leechcraft/lc-blasq/lc-blasq-9999.ebuild b/app-leechcraft/lc-blasq/lc-blasq-9999.ebuild
index 7453543ccab..13375b498d5 100644
--- a/app-leechcraft/lc-blasq/lc-blasq-9999.ebuild
+++ b/app-leechcraft/lc-blasq/lc-blasq-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
inherit leechcraft
@@ -12,19 +12,29 @@ SLOT="0"
KEYWORDS=""
IUSE="debug +deathnote +rappor +spegnersi +vangog"
-DEPEND="~app-leechcraft/lc-core-${PV}
- deathnote? ( dev-qt/qtxmlpatterns:4 )
- spegnersi? ( dev-libs/kqoauth )
- vangog? ( dev-libs/qjson )
- "
+DEPEND="
+ ~app-leechcraft/lc-core-${PV}
+ dev-qt/qtwidgets:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtdeclarative:5
+ rappor? ( dev-qt/qtxml:5 )
+ deathnote? (
+ dev-qt/qtxml:5
+ dev-qt/qtxmlpatterns:5
+ )
+ spegnersi? (
+ dev-libs/kqoauth
+ dev-qt/qtxml:5
+ )
+ vangog? ( dev-qt/qtxml:5 )"
RDEPEND="${DEPEND}"
src_configure(){
local mycmakeargs=(
- $(cmake-utils_use_enable deathnote BLASQ_DEATHNOTE)
- $(cmake-utils_use_enable rappor BLASQ_RAPPOR)
- $(cmake-utils_use_enable spegnersi BLASQ_SPEGNERSI)
- $(cmake-utils_use_enable vangog BLASQ_VANGOG)
+ -DENABLE_BLASQ_DEATHNOTE=$(usex deathnote)
+ -DENABLE_BLASQ_RAPPOR=$(usex rappor)
+ -DENABLE_BLASQ_SPEGNERSI=$(usex spegnersi)
+ -DENABLE_BLASQ_VANGOG=$(usex vangog)
)
cmake-utils_src_configure