summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-gmailnotifier
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2017-02-25 19:49:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-26 12:58:56 +0100
commit09222bd0523d448c79f1434b042f55e440097adf (patch)
tree899893b57e6ed056d7eb0f4350388ccbedbc6b90 /app-leechcraft/lc-gmailnotifier
parent99d36d2e957164374ebcc9fa990509dc2f81833f (diff)
downloadgentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.gz
gentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.xz
app-leechcraft: use Qt5, modernize the eclass and ebuilds
Closes: https://github.com/gentoo/gentoo/pull/4079
Diffstat (limited to 'app-leechcraft/lc-gmailnotifier')
-rw-r--r--app-leechcraft/lc-gmailnotifier/lc-gmailnotifier-9999.ebuild12
-rw-r--r--app-leechcraft/lc-gmailnotifier/metadata.xml8
2 files changed, 14 insertions, 6 deletions
diff --git a/app-leechcraft/lc-gmailnotifier/lc-gmailnotifier-9999.ebuild b/app-leechcraft/lc-gmailnotifier/lc-gmailnotifier-9999.ebuild
index 7c320e71878..1b43936c8e5 100644
--- a/app-leechcraft/lc-gmailnotifier/lc-gmailnotifier-9999.ebuild
+++ b/app-leechcraft/lc-gmailnotifier/lc-gmailnotifier-9999.ebuild
@@ -1,19 +1,23 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
inherit leechcraft
-DESCRIPTION="Notifier about new mail in a GMail inbox for LeechCraft"
+DESCRIPTION="Notifies about new mail in a GMail inbox for LeechCraft"
SLOT="0"
KEYWORDS=""
IUSE="debug notify quark"
DEPEND="~app-leechcraft/lc-core-${PV}
- dev-qt/qtdeclarative:4"
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtxml:5
+"
RDEPEND="${DEPEND}
quark? ( ~virtual/leechcraft-quark-sideprovider-${PV} )
notify? ( ~virtual/leechcraft-notifier-${PV} )"
diff --git a/app-leechcraft/lc-gmailnotifier/metadata.xml b/app-leechcraft/lc-gmailnotifier/metadata.xml
index 3fdc6e37e83..c92c33ea77c 100644
--- a/app-leechcraft/lc-gmailnotifier/metadata.xml
+++ b/app-leechcraft/lc-gmailnotifier/metadata.xml
@@ -1,9 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>0xd34df00d@gmail.com</email>
+ <name>Georg Rudoy</name>
+ </maintainer>
<maintainer type="project">
- <email>leechcraft@gentoo.org</email>
- <name>LeechCraft</name>
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
</maintainer>
<use>
<flag name="quark">Pull in a plugin to show GMail Notifier's quark</flag>