summaryrefslogtreecommitdiff
path: root/app-leechcraft/lc-lmp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-leechcraft/lc-lmp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-leechcraft/lc-lmp')
-rw-r--r--app-leechcraft/lc-lmp/Manifest3
-rw-r--r--app-leechcraft/lc-lmp/lc-lmp-0.6.60.ebuild32
-rw-r--r--app-leechcraft/lc-lmp/lc-lmp-0.6.65.ebuild32
-rw-r--r--app-leechcraft/lc-lmp/lc-lmp-0.6.70.ebuild35
-rw-r--r--app-leechcraft/lc-lmp/lc-lmp-9999.ebuild40
-rw-r--r--app-leechcraft/lc-lmp/metadata.xml13
6 files changed, 155 insertions, 0 deletions
diff --git a/app-leechcraft/lc-lmp/Manifest b/app-leechcraft/lc-lmp/Manifest
new file mode 100644
index 00000000000..1911f838b33
--- /dev/null
+++ b/app-leechcraft/lc-lmp/Manifest
@@ -0,0 +1,3 @@
+DIST leechcraft-0.6.60.tar.xz 5089252 SHA256 669c2325235c3c49dfc9a30d38c1ad08c0a6abf1ebbf2c8d33eca27e976e1b6d SHA512 0bac75f96bfc43c692e8b61ba5e9b6b82d535a78bd310966c36579666feb8b87217a9d74cfe792fa32b57b9b04e158239acbf2422014735d2316cbda2d8b39ec WHIRLPOOL f3056faab0006830afbcf5f3448094e530c908d432cebec731f305f34347e514db55416a911674c28445a3cd4e542136fd053ee5e444b3cf93e086dc9e88428c
+DIST leechcraft-0.6.65.tar.xz 5067580 SHA256 b821fb8716b3ba04862bbb358a738609ead84cd9c86b569fe31c712b48c2a7fd SHA512 94e3cfa42bea572cb2feeaf4c7153c8d7e08e0597d447db5033b72222cea67370e8948d0dd0e2b89585583a88b4ee3df7b32d72dcd624d383e79b9472ceffe30 WHIRLPOOL bc589f46c89351328e25e6e32febdcba8ead639a8d1daf18df7352372d66fb8f8e7e5bbef02d49b6a00a7f5ffa15d66699b79cc73f64ea1bf8b59949fcd81b8a
+DIST leechcraft-0.6.70.tar.xz 5204940 SHA256 3e7f51da0b7eec6df11471ada409d752754f3badc388b8f0adab3f056fabcd45 SHA512 fedf0467e39bd512c937b25f5da62af2be7908831169e1d82d10af43b7c164be2658138663578d7658c3692d5269dd3df9e391744561443f49771edd063ba408 WHIRLPOOL a0aef0bdc11d4b3a3680a055671208db0528bb4744930a0fecab6d1fbf99cc87f4fd8483e98e93357a4c0dda1f3edc1a20a9a725b28ea9003c564469531a2d37
diff --git a/app-leechcraft/lc-lmp/lc-lmp-0.6.60.ebuild b/app-leechcraft/lc-lmp/lc-lmp-0.6.60.ebuild
new file mode 100644
index 00000000000..90078cad4ac
--- /dev/null
+++ b/app-leechcraft/lc-lmp/lc-lmp-0.6.60.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="LeechCraft Media Player, Phonon-based audio/video player"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug +graffiti +guess +mpris +mp3tunes"
+
+# depend on gstreamer:0.10 to match current Qt deps
+DEPEND="~app-leechcraft/lc-core-${PV}
+ graffiti? ( media-libs/flac )
+ guess? ( app-i18n/libguess )
+ media-libs/gstreamer:0.10
+ media-libs/taglib
+ mpris? ( dev-qt/qtdbus:4 )
+ dev-qt/qtdeclarative:4"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable graffiti LMP_GRAFFITI)
+ $(cmake-utils_use_enable guess LMP_LIBGUESS)
+ $(cmake-utils_use_enable mpris LMP_MPRIS)
+ $(cmake-utils_use_enable mp3tunes LMP_MP3TUNES)"
+ cmake-utils_src_configure
+}
diff --git a/app-leechcraft/lc-lmp/lc-lmp-0.6.65.ebuild b/app-leechcraft/lc-lmp/lc-lmp-0.6.65.ebuild
new file mode 100644
index 00000000000..f432d62c2c4
--- /dev/null
+++ b/app-leechcraft/lc-lmp/lc-lmp-0.6.65.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="LeechCraft Media Player, Phonon-based audio/video player"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug +graffiti +guess +mpris +mp3tunes"
+
+# depend on gstreamer:0.10 to match current Qt deps
+DEPEND="~app-leechcraft/lc-core-${PV}
+ graffiti? ( media-libs/flac )
+ guess? ( app-i18n/libguess )
+ media-libs/gstreamer:0.10
+ media-libs/taglib
+ mpris? ( dev-qt/qtdbus:4 )
+ dev-qt/qtdeclarative:4"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable graffiti LMP_GRAFFITI)
+ $(cmake-utils_use_enable guess LMP_LIBGUESS)
+ $(cmake-utils_use_enable mpris LMP_MPRIS)
+ $(cmake-utils_use_enable mp3tunes LMP_MP3TUNES)"
+ cmake-utils_src_configure
+}
diff --git a/app-leechcraft/lc-lmp/lc-lmp-0.6.70.ebuild b/app-leechcraft/lc-lmp/lc-lmp-0.6.70.ebuild
new file mode 100644
index 00000000000..cca5b5d4b7c
--- /dev/null
+++ b/app-leechcraft/lc-lmp/lc-lmp-0.6.70.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="LeechCraft Media Player, Phonon-based audio/video player"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug +fradj +graffiti +guess +mpris +mp3tunes potorchu"
+
+# depend on gstreamer:0.10 to match current Qt deps
+DEPEND="~app-leechcraft/lc-core-${PV}
+ graffiti? ( media-libs/flac )
+ guess? ( app-i18n/libguess )
+ media-libs/gstreamer:0.10
+ media-libs/taglib
+ mpris? ( dev-qt/qtdbus:4 )
+ potorchu? ( media-libs/libprojectm )
+ dev-qt/qtdeclarative:4"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable fradj LMP_FRADJ)
+ $(cmake-utils_use_enable graffiti LMP_GRAFFITI)
+ $(cmake-utils_use_enable guess LMP_LIBGUESS)
+ $(cmake-utils_use_enable mpris LMP_MPRIS)
+ $(cmake-utils_use_enable mp3tunes LMP_MP3TUNES)
+ $(cmake-utils_use_enable potorchu LMP_POTORCHU)"
+ cmake-utils_src_configure
+}
diff --git a/app-leechcraft/lc-lmp/lc-lmp-9999.ebuild b/app-leechcraft/lc-lmp/lc-lmp-9999.ebuild
new file mode 100644
index 00000000000..c2891fa8e25
--- /dev/null
+++ b/app-leechcraft/lc-lmp/lc-lmp-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="LeechCraft Media Player, Phonon-based audio/video player"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +fradj +graffiti +guess +mpris +mtp +mp3tunes potorchu"
+
+# depend on gstreamer:0.10 to match current Qt deps
+DEPEND="~app-leechcraft/lc-core-${PV}
+ graffiti? ( media-libs/flac )
+ guess? ( app-i18n/libguess )
+ media-libs/gstreamer:0.10
+ media-libs/taglib
+ mpris? ( dev-qt/qtdbus:4 )
+ mtp? (
+ ~app-leechcraft/lc-devmon-${PV}
+ media-libs/libmtp
+ )
+ potorchu? ( media-libs/libprojectm )
+ dev-qt/qtdeclarative:4"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable fradj LMP_FRADJ)
+ $(cmake-utils_use_enable graffiti LMP_GRAFFITI)
+ $(cmake-utils_use_enable guess LMP_LIBGUESS)
+ $(cmake-utils_use_enable mpris LMP_MPRIS)
+ $(cmake-utils_use_enable mtp LMP_MTPSYNC)
+ $(cmake-utils_use_enable mp3tunes LMP_MP3TUNES)
+ $(cmake-utils_use_enable potorchu LMP_POTORCHU)"
+ cmake-utils_src_configure
+}
diff --git a/app-leechcraft/lc-lmp/metadata.xml b/app-leechcraft/lc-lmp/metadata.xml
new file mode 100644
index 00000000000..e080d2300e0
--- /dev/null
+++ b/app-leechcraft/lc-lmp/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>leechcraft</herd>
+<use>
+ <flag name="fradj">Build FrAdj, the equalizer effect module</flag>
+ <flag name="graffiti">Build media tags editor plugin</flag>
+ <flag name="guess">Enable tags encoding guessing via the libguess library</flag>
+ <flag name="mpris">Enable MPRIS support</flag>
+ <flag name="mp3tunes">Build plugin for supporting the mp3tunes.com music locker service</flag>
+ <flag name="potorchu"> Enable the projectM-based visualization effects module for LMP</flag>
+</use>
+</pkgmetadata>