summaryrefslogtreecommitdiff
path: root/app-metrics
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-27 15:43:32 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-03-27 16:10:55 +0200
commit8bc3a018a783b7c6026a55e945c795212db1b688 (patch)
tree594fc5247220e1a5b496576c99eb645b1e1644a3 /app-metrics
parent7b42402f44381ab55416c810e49d7d8155c6334a (diff)
downloadgentoo-8bc3a018a783b7c6026a55e945c795212db1b688.tar.gz
gentoo-8bc3a018a783b7c6026a55e945c795212db1b688.tar.xz
app-metrics/buildbot-prometheus: Move package from dev-util/buildbot-prometheus
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/buildbot-prometheus/Manifest1
-rw-r--r--app-metrics/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild30
-rw-r--r--app-metrics/buildbot-prometheus/buildbot-prometheus-17.7.2-r2.ebuild35
-rw-r--r--app-metrics/buildbot-prometheus/buildbot-prometheus-17.7.2.ebuild26
-rw-r--r--app-metrics/buildbot-prometheus/files/buildbot-prometheus-17.7.2-Migrate-duration-calculations-to-buildbot-09.patch52
-rw-r--r--app-metrics/buildbot-prometheus/metadata.xml16
6 files changed, 160 insertions, 0 deletions
diff --git a/app-metrics/buildbot-prometheus/Manifest b/app-metrics/buildbot-prometheus/Manifest
new file mode 100644
index 00000000000..0cc6923df04
--- /dev/null
+++ b/app-metrics/buildbot-prometheus/Manifest
@@ -0,0 +1 @@
+DIST buildbot-prometheus-17.7.2.tar.gz 10101 BLAKE2B 25c060b5368aa1dea6145b6d380db8001f3cd1fb49f9b3bb1e4ecccdb771591abc269d5aee9d022a9b182b19650a0c398b580004f20def0675b86ca9f3a1e2db SHA512 8a0ecaf57eade3d69fabc57a19a1c02af8e398c3bc4732e40f39e8904a16c9b751d4f6f8ace0dd7893b380d1ffc8a51360279aeb7b4059a6cd9438145344e74b
diff --git a/app-metrics/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild b/app-metrics/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild
new file mode 100644
index 00000000000..f6c6bd792ce
--- /dev/null
+++ b/app-metrics/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A Prometheus metrics exporter for Buildbot"
+HOMEPAGE="https://github.com/claws/buildbot-prometheus"
+SRC_URI="https://github.com/claws/buildbot-prometheus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/prometheus_client[${PYTHON_USEDEP}]
+ dev-util/buildbot[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
+
+PATCHES=(
+ "$FILESDIR}/buildbot-prometheus-17.7.2-Migrate-duration-calculations-to-buildbot-09.patch"
+)
+
+python_prepare_all() {
+ sed -i -e "/^install_reqs.*$/d" -e "/^from pip.*$/d" -e "s/requires = .*/requires = ['buildbot', 'prometheus_client']/" setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/app-metrics/buildbot-prometheus/buildbot-prometheus-17.7.2-r2.ebuild b/app-metrics/buildbot-prometheus/buildbot-prometheus-17.7.2-r2.ebuild
new file mode 100644
index 00000000000..67323d1dbef
--- /dev/null
+++ b/app-metrics/buildbot-prometheus/buildbot-prometheus-17.7.2-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A Prometheus metrics exporter for Buildbot"
+HOMEPAGE="https://github.com/claws/buildbot-prometheus"
+SRC_URI="https://github.com/claws/buildbot-prometheus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/prometheus_client[${PYTHON_USEDEP}]
+ >=dev-util/buildbot-0.9.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/buildbot-prometheus-17.7.2-Migrate-duration-calculations-to-buildbot-09.patch"
+)
+
+python_prepare_all() {
+ sed -i -e "/^install_reqs.*$/d" -e "/^from pip.*$/d" -e "s/requires = .*/requires = ['buildbot', 'prometheus_client']/" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ einfo "This version has been patched to be compatible with the current buildbot releases >=0.9.0"
+ einfo "For older buildbot-0.8* releases, please use dev-python/buildbot-prometheus-17.7.2-r1 version"
+}
diff --git a/app-metrics/buildbot-prometheus/buildbot-prometheus-17.7.2.ebuild b/app-metrics/buildbot-prometheus/buildbot-prometheus-17.7.2.ebuild
new file mode 100644
index 00000000000..a930624175f
--- /dev/null
+++ b/app-metrics/buildbot-prometheus/buildbot-prometheus-17.7.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A Prometheus metrics exporter for Buildbot"
+HOMEPAGE="https://github.com/claws/buildbot-prometheus"
+SRC_URI="https://github.com/claws/buildbot-prometheus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/prometheus_client[${PYTHON_USEDEP}]
+ dev-util/buildbot[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
+
+python_prepare_all() {
+ sed -i -e "/^install_reqs.*$/d" -e "/^from pip.*$/d" -e "s/requires = .*/requires = ['buildbot', 'prometheus_client']/" setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/app-metrics/buildbot-prometheus/files/buildbot-prometheus-17.7.2-Migrate-duration-calculations-to-buildbot-09.patch b/app-metrics/buildbot-prometheus/files/buildbot-prometheus-17.7.2-Migrate-duration-calculations-to-buildbot-09.patch
new file mode 100644
index 00000000000..0ba69478ac7
--- /dev/null
+++ b/app-metrics/buildbot-prometheus/files/buildbot-prometheus-17.7.2-Migrate-duration-calculations-to-buildbot-09.patch
@@ -0,0 +1,52 @@
+From ceddea3f55773e104c628ef6316ce74785d235f3 Mon Sep 17 00:00:00 2001
+From: °RÓ¨ < _â>
+Date: Tue, 6 Mar 2018 02:30:56 +0000
+Subject: [PATCH] Migrate duration calculations to >=buildbot-0.9
+
+---
+ buildbot_prometheus/prometheus.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/buildbot_prometheus/prometheus.py b/buildbot_prometheus/prometheus.py
+index a766f41..ebf41a1 100644
+--- a/buildbot_prometheus/prometheus.py
++++ b/buildbot_prometheus/prometheus.py
+@@ -302,7 +302,7 @@ class Prometheus(service.BuildbotService):
+ build_started = msg['started_at']
+ build_finished = msg['complete_at']
+ build_duration = build_finished - build_started
+- duration_seconds = build_duration.total_seconds()
++ duration_seconds = build_duration
+ self.g_builds_duration.labels(**labels).set(duration_seconds)
+
+ build_status = resolve_results_status(msg['results'])
+@@ -401,7 +401,7 @@ class Prometheus(service.BuildbotService):
+ buildset_started = msg['submitted_at']
+ buildset_finished = msg['complete_at']
+ buildset_duration = buildset_finished - buildset_started
+- duration_seconds = buildset_duration.total_seconds()
++ duration_seconds = buildset_duration
+ self.g_buildsets_duration.labels(**labels).set(duration_seconds)
+
+ bs_success = resolve_results_status(msg['results'])
+@@ -444,7 +444,7 @@ class Prometheus(service.BuildbotService):
+ br_started = msg['submitted_at']
+ br_finished = msg['complete_at']
+ br_duration = br_finished - br_started
+- duration_seconds = br_duration.total_seconds()
++ duration_seconds = br_duration
+ self.g_build_requests_duration.labels(**labels).set(duration_seconds)
+
+ br_success = resolve_results_status(msg['results'])
+@@ -491,7 +491,7 @@ class Prometheus(service.BuildbotService):
+ step_started = msg['started_at']
+ step_finished = msg['complete_at']
+ step_duration = step_finished - step_started
+- duration_seconds = step_duration.total_seconds()
++ duration_seconds = step_duration
+ self.g_steps_duration.labels(**labels).set(duration_seconds)
+
+ step_success = resolve_results_status(msg['results'])
+--
+libgit2 0.24.6
+
diff --git a/app-metrics/buildbot-prometheus/metadata.xml b/app-metrics/buildbot-prometheus/metadata.xml
new file mode 100644
index 00000000000..81ebfb154a1
--- /dev/null
+++ b/app-metrics/buildbot-prometheus/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">buildbot-prometheus</remote-id>
+ <remote-id type="github">claws/buildbot-prometheus</remote-id>
+ </upstream>
+</pkgmetadata>