summaryrefslogtreecommitdiff
path: root/app-misc/asciinema/asciinema-1.3.0.ebuild
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-08-22 04:22:54 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-08-22 04:42:45 +1000
commitc61592ff86f3fc25851e5cfe88a0709d60c11d23 (patch)
tree2af13290cd3385aede8550bef2881250aaac40fe /app-misc/asciinema/asciinema-1.3.0.ebuild
parentdea20dc0ea28148a7715d5f98acbd5792645ba31 (diff)
downloadgentoo-c61592ff86f3fc25851e5cfe88a0709d60c11d23.tar.gz
gentoo-c61592ff86f3fc25851e5cfe88a0709d60c11d23.tar.xz
app-misc/asciinema: version bump
Gentoo-bug: 532918 Package-Manager: portage-2.3.0
Diffstat (limited to 'app-misc/asciinema/asciinema-1.3.0.ebuild')
-rw-r--r--app-misc/asciinema/asciinema-1.3.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/asciinema/asciinema-1.3.0.ebuild b/app-misc/asciinema/asciinema-1.3.0.ebuild
new file mode 100644
index 00000000000..3295bb3ccc5
--- /dev/null
+++ b/app-misc/asciinema/asciinema-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_3,3_4})
+inherit distutils-r1
+
+DESCRIPTION="Command line recorder for asciinema.org service"
+HOMEPAGE="https://asciinema.org/ https://pypi.python.org/pypi/asciinema"
+SRC_URI="https://github.com/asciinema/asciinema/archive/v1.3.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md doc/asciicast-v1.md )
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # obsolete, already removed in upstream git
+ rm asciinema/requests_http_adapter.py
+}
+
+python_test() {
+ nosetests || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman man/asciinema.1
+}