summaryrefslogtreecommitdiff
path: root/app-misc/bgrep
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/bgrep
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/bgrep')
-rw-r--r--app-misc/bgrep/Manifest1
-rw-r--r--app-misc/bgrep/bgrep-0_p20110121.ebuild46
-rw-r--r--app-misc/bgrep/metadata.xml10
3 files changed, 57 insertions, 0 deletions
diff --git a/app-misc/bgrep/Manifest b/app-misc/bgrep/Manifest
new file mode 100644
index 00000000000..65783f0296a
--- /dev/null
+++ b/app-misc/bgrep/Manifest
@@ -0,0 +1 @@
+DIST tmbinc-bgrep-49b098b.tar.gz 3386 SHA256 036e2843cc33170e8ee9aa640055f7e4c37d7268ace59fd23cfa19d420752c70 SHA512 18a0161fe23a04d36bbfe67712a90b3d30c4cca95fed023773b0a1eda5fc1c284996d9669eec256a9aacc7019297f96c3d4fe69c240595bcdcc3a8b7c1bea990 WHIRLPOOL e6f9ac1efb5730d4e32bb707148bd331adadaccd3a468a3157705f2667c0797677ece018f8c20db1df0862cf7a1d351716c0ae845d60e826b786d0aab88102fb
diff --git a/app-misc/bgrep/bgrep-0_p20110121.ebuild b/app-misc/bgrep/bgrep-0_p20110121.ebuild
new file mode 100644
index 00000000000..32c01288157
--- /dev/null
+++ b/app-misc/bgrep/bgrep-0_p20110121.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+GITHUB_USER="tmbinc"
+GITHUB_HASH="49b098be9548d174023ad05c10f6af9d02b8e18e"
+MY_P="${GITHUB_USER}-${PN}-${GITHUB_HASH:0:7}"
+
+inherit toolchain-funcs
+
+DESCRIPTION="grep-like tool to search for binary strings"
+HOMEPAGE="https://github.com/tmbinc/bgrep/"
+SRC_URI="https://github.com/${GITHUB_USER}/${PN}/tarball/${GITHUB_HASH} -> ${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+IUSE="test"
+
+RDEPEND=""
+DEPEND="test? ( dev-lang/perl )"
+
+src_prepare() {
+ sed -i -e "s|/tmp/|${T}/|g" \
+ test/bgrep-test.sh || die
+}
+
+src_compile() {
+ tc-export CC
+ emake || die
+}
+
+src_test() {
+ cd test
+ ./bgrep-test.sh || die
+}
+
+src_install() {
+ dobin bgrep
+ dodoc README
+}
diff --git a/app-misc/bgrep/metadata.xml b/app-misc/bgrep/metadata.xml
new file mode 100644
index 00000000000..f7d75d1eedf
--- /dev/null
+++ b/app-misc/bgrep/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tmbinc/bgrep</remote-id>
+ </upstream>
+</pkgmetadata>