summaryrefslogtreecommitdiff
path: root/app-misc/birthday
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/birthday
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/birthday')
-rw-r--r--app-misc/birthday/Manifest1
-rw-r--r--app-misc/birthday/birthday-1.6.2.ebuild31
-rw-r--r--app-misc/birthday/metadata.xml8
3 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/birthday/Manifest b/app-misc/birthday/Manifest
new file mode 100644
index 00000000000..18dabee0e81
--- /dev/null
+++ b/app-misc/birthday/Manifest
@@ -0,0 +1 @@
+DIST birthday-1.6.2.tar.bz2 85617 SHA256 355ad07ad3312d8f5c5b54c71596ac3a0e706c539167900d73cb65df30c8e2f4 SHA512 5081cd9f875260758d209165803715d3eb19e2256344172cb3ea01f87f859215ce68e29174c22eec467bdb6eebc11627a71674321bb9b96db9562d13cdc80882 WHIRLPOOL 226a0293a2a3b91dfd6eae09680a7e2df56de1c2329332574c2d4eb5be9520106309cccead7c71439d5b9f3149798d25321c167eda2ead3f972630698cd6665b
diff --git a/app-misc/birthday/birthday-1.6.2.ebuild b/app-misc/birthday/birthday-1.6.2.ebuild
new file mode 100644
index 00000000000..600b93523b1
--- /dev/null
+++ b/app-misc/birthday/birthday-1.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays a list of events happening in the near future"
+HOMEPAGE="http://sourceforge.net/projects/birthday/"
+SRC_URI="mirror://sourceforge/birthday/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't strip, install in correct share dir and respect CFLAGS
+ sed -i -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/app-misc/birthday/metadata.xml b/app-misc/birthday/metadata.xml
new file mode 100644
index 00000000000..66d5c054373
--- /dev/null
+++ b/app-misc/birthday/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <upstream>
+ <remote-id type="sourceforge">birthday</remote-id>
+ </upstream>
+</pkgmetadata>