summaryrefslogtreecommitdiff
path: root/app-misc/ddcutil
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2017-08-15 18:33:35 +0100
committerMichał Górny <mgorny@gentoo.org>2017-08-16 23:00:05 +0200
commit0ca6428b2c899847598863af3589e235a42d3573 (patch)
treea37a4bd6114107116e12a1b8895eff54ba6680d4 /app-misc/ddcutil
parent787c7383d501e186dd8e1c578f8594ae59ba62de (diff)
downloadgentoo-0ca6428b2c899847598863af3589e235a42d3573.tar.gz
gentoo-0ca6428b2c899847598863af3589e235a42d3573.tar.xz
app-misc/ddcutil: version bump to 0.8.4
Drop use flag api-libs. Signed-off by: Jonathan Scruggs (j.scruggs@gmail.com)
Diffstat (limited to 'app-misc/ddcutil')
-rw-r--r--app-misc/ddcutil/Manifest1
-rw-r--r--app-misc/ddcutil/ddcutil-0.8.4.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/app-misc/ddcutil/Manifest b/app-misc/ddcutil/Manifest
index a835be4598e..cebe3bb32e4 100644
--- a/app-misc/ddcutil/Manifest
+++ b/app-misc/ddcutil/Manifest
@@ -1 +1,2 @@
DIST ddcutil-0.7.1.tar.gz 429744 SHA256 e73e2332d4b8c861026fed3886630b975e85fbda5efeba2866214ef16eaef5c6 SHA512 1bae833298d3d5dbdb235c09905c7325d98e090ee5a2c61abb843680ce1c8e13e700f2b04055d68f72f8e44a930e748e0214adc969909510fc8dcd32431323b6 WHIRLPOOL dcfc663d3e3bcdfa687c069b0c2b7ec8381505cab18e3c4b98b30f6629d2b45ff2a715547087fbaa26b8ba281d1f3c87bd4f670e3b861696041c296fded835e0
+DIST ddcutil-0.8.4.tar.gz 558405 SHA256 7bfa9bd1dad7aac1853cf1070d2becf47156c158b84ae874cd77e8fd7d4e44d5 SHA512 e7bf78295a008607ef520e055873acc0bac6d94b850a6ea1f7d4a4ea9e080d23b4b7d82e5725a220ff120ab1523aa320265ba22671982625c10088521c72a14c WHIRLPOOL 3637a3a03a5a4d402f1ca3dcf0ecee8cd361735cff1ffce4a2e862ad9c87fe12cd09a782c5c2b6bfd53e94547eecf29c344ce918217931593e07a4a207bf241a
diff --git a/app-misc/ddcutil/ddcutil-0.8.4.ebuild b/app-misc/ddcutil/ddcutil-0.8.4.ebuild
new file mode 100644
index 00000000000..703177064be
--- /dev/null
+++ b/app-misc/ddcutil/ddcutil-0.8.4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info udev user
+
+DESCRIPTION="Program for querying and changing monitor settings"
+HOMEPAGE="http://www.ddcutil.com/"
+SRC_URI="https://github.com/rockowitz/ddcutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# Binary drivers need special instructions compared to the open source counterparts.
+# If a user switches drivers, they will need to set different use flags for
+# Xorg or Wayland or Mesa, so this will trigger the rebuild against
+# the different drivers.
+# Remove ATI/AMD driver since it's masked for removal.
+# Will most likely need to set this for AMDGPU when in portage.
+IUSE="usb-monitor user-permissions video_cards_nvidia"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libX11
+ dev-libs/glib:2
+ sys-apps/i2c-tools
+ virtual/udev
+ usb-monitor? (
+ dev-libs/hidapi
+ virtual/libusb:1
+ sys-apps/usbutils )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+pkg_pretend() {
+ # This program needs /dev/ic2-* devices to communicate with the monitor.
+ CONFIG_CHECK="~I2C_CHARDEV"
+ ERROR_I2C_CHARDEV="You must enable I2C_CHARDEV in your kernel to continue"
+ if use usb-monitor; then
+ CONFIG_CHECK+=" ~HIDRAW ~USB_HIDDEV"
+ ERROR_HIDRAW="HIDRAW is needed to support USB monitors"
+ ERROR_I2C_CHARDEV="USB_HIDDEV is needed to support USB monitors"
+ fi
+
+ # Now do the actual checks setup above
+ check_extra_config
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Python API is still very experimental.
+ local myeconfargs=(
+ $(use_enable usb-monitor usb)
+ --disable-swig
+ --enable-lib
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ if use user-permissions; then
+ udev_dorules data/etc/udev/rules.d/45-ddcutil-i2c.rules
+ if use usb-monitor; then
+ udev_dorules data/etc/udev/rules.d/45-ddcutil-usb.rules
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use user-permissions; then
+ enewgroup i2c
+ einfo "To allow non-root users access to the /dev/i2c-* devices, add those"
+ einfo "users to the i2c group: usermod -aG i2c user"
+ einfo "Restart the computer or reload the i2c-dev module to activate"
+ einfo "the new udev rule."
+ einfo "For more information read: http://www.ddcutil.com/i2c_permissions/"
+
+ if use usb-monitor; then
+ enewgroup video
+ einfo "To allow non-root users access to USB monitors, add those users"
+ einfo "to the video group: usermod -aG video user"
+ einfo "Restart the computer, reload the hiddev and hidraw modules, or replug"
+ einfo "the monitor to activate the new udev rule."
+ einfo "For more information read: http://www.ddcutil.com/usb/"
+ fi
+
+ udev_reload
+ fi
+
+ if use video_cards_nvidia; then
+ ewarn "Please read the following webpage on proper usage with the nVidia "
+ ewarn "binary drivers, or it may not work: http://www.ddcutil.com/nvidia/"
+ fi
+}