summaryrefslogtreecommitdiff
path: root/app-misc/detox
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/detox
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/detox')
-rw-r--r--app-misc/detox/Manifest1
-rw-r--r--app-misc/detox/detox-1.2.0-r3.ebuild47
-rw-r--r--app-misc/detox/files/detox-1.2.0-LDFLAGS.patch18
-rw-r--r--app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch17
-rw-r--r--app-misc/detox/files/detox-1.2.0-format-security.patch72
-rw-r--r--app-misc/detox/files/detox-1.2.0-install-missing-file.patch18
-rw-r--r--app-misc/detox/files/detox-1.2.0-parallel.patch29
-rw-r--r--app-misc/detox/metadata.xml8
8 files changed, 210 insertions, 0 deletions
diff --git a/app-misc/detox/Manifest b/app-misc/detox/Manifest
new file mode 100644
index 00000000000..f1c3905a54a
--- /dev/null
+++ b/app-misc/detox/Manifest
@@ -0,0 +1 @@
+DIST detox-1.2.0.tar.bz2 86118 SHA256 abfad90ee7d3e0fc53ce3b9da3253f9a800cdd92e3f8cc12a19394a7b1dcdbf8 SHA512 48c0060ed0538c26aeba444bf327f1e52ea47d0e696577deeb43304dfb960ee5abe984651948bfc67c51d7f15f9051df2a208acfe53a5778a7471460e87f639a WHIRLPOOL f8169f10e1713e3b2fd3ea736b22d0c024d6698bb2e80c30124bbf70be0afb764d496df5fba4f5b68383327590b2c90dd0ebb2481c0b62859ceb26a820265657
diff --git a/app-misc/detox/detox-1.2.0-r3.ebuild b/app-misc/detox/detox-1.2.0-r3.ebuild
new file mode 100644
index 00000000000..4d5e09afc74
--- /dev/null
+++ b/app-misc/detox/detox-1.2.0-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="Safely remove spaces and strange characters from filenames"
+HOMEPAGE="http://detox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~mips ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-parallel.patch
+ "${FILESDIR}"/${P}-LDFLAGS.patch
+ "${FILESDIR}"/${P}-change-default-sequence-to-use-utf8-table.patch
+ "${FILESDIR}"/${P}-install-missing-file.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ )
+
+src_prepare() {
+ sed \
+ -e 's:Fl c Ar:Fl f Ar:g' \
+ -i ${PN}.1 || die
+ epatch "${PATCHES[@]}"
+ sed \
+ -e '/detoxrc.sample/d' \
+ -i Makefile.in || die
+}
+
+src_configure() {
+ econf --with-popt="${EPREFIX}/usr"
+}
diff --git a/app-misc/detox/files/detox-1.2.0-LDFLAGS.patch b/app-misc/detox/files/detox-1.2.0-LDFLAGS.patch
new file mode 100644
index 00000000000..3f0daa08801
--- /dev/null
+++ b/app-misc/detox/files/detox-1.2.0-LDFLAGS.patch
@@ -0,0 +1,18 @@
+https://sourceforge.net/tracker/index.php?func=detail&aid=2166388&group_id=101612&atid=630105
+
+--- Makefile.in 2008-10-14 16:37:22 +0000
++++ Makefile.in 2008-10-14 16:38:17 +0000
+@@ -70,10 +70,10 @@
+ #
+
+ detox: ${detoxOBJS}
+- ${CC} -o detox ${detoxOBJS} ${L_OPT}
++ ${CC} ${LDFLAGS} -o detox ${detoxOBJS} ${L_OPT}
+
+ inline-detox: ${inline-detoxOBJS}
+- ${CC} -o inline-detox ${inline-detoxOBJS} ${L_OPT}
++ ${CC} ${LDFLAGS} -o inline-detox ${inline-detoxOBJS} ${L_OPT}
+
+ #
+ # Special Source Compiles
+
diff --git a/app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch b/app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch
new file mode 100644
index 00000000000..2e54642f45b
--- /dev/null
+++ b/app-misc/detox/files/detox-1.2.0-change-default-sequence-to-use-utf8-table.patch
@@ -0,0 +1,17 @@
+# Patch from Teemu Likonen <tlikonen@iki.fi>
+# to change the default sequence to use utf8 instead of iso8859-1
+--- detox-1.2.0/detoxrc~ 2006-07-03 19:45:54.000000000 +0300
++++ detox-1.2.0/detoxrc 2009-05-28 15:34:26.497832449 +0300
+@@ -32,10 +32,10 @@
+ #
+
+ #
+-# Basically just ISO8859_1
++# Basically just utf_8
+ #
+ sequence default {
+- iso8859_1;
++ utf_8;
+ safe;
+ wipeup;
+ };
diff --git a/app-misc/detox/files/detox-1.2.0-format-security.patch b/app-misc/detox/files/detox-1.2.0-format-security.patch
new file mode 100644
index 00000000000..c03a98aa046
--- /dev/null
+++ b/app-misc/detox/files/detox-1.2.0-format-security.patch
@@ -0,0 +1,72 @@
+ parse_options_getopt.c | 8 ++++----
+ parse_options_popt.c | 8 ++++----
+ 2 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/parse_options_getopt.c b/parse_options_getopt.c
+index 1f80966..ea2b266 100644
+--- a/parse_options_getopt.c
++++ b/parse_options_getopt.c
+@@ -98,9 +98,9 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
+ #endif
+ switch (optcode) {
+ case 'h':
+- printf(usage_message);
++ printf("%s", usage_message);
+ printf("\n");
+- printf(help_message);
++ printf("%s", help_message);
+ exit(EXIT_SUCCESS);
+
+ case 'f':
+@@ -138,7 +138,7 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
+ exit(EXIT_SUCCESS);
+
+ case '?':
+- printf(usage_message);
++ printf("%s", usage_message);
+ exit(EXIT_SUCCESS);
+
+ case 0:
+@@ -195,7 +195,7 @@ struct detox_options *parse_options_getopt(int argc, char **argv)
+ }
+ else {
+ #ifndef INLINE_MODE
+- printf(usage_message);
++ printf("%s", usage_message);
+ exit(EXIT_FAILURE);
+ #endif
+ }
+diff --git a/parse_options_popt.c b/parse_options_popt.c
+index 60dad7a..370c3cc 100644
+--- a/parse_options_popt.c
++++ b/parse_options_popt.c
+@@ -94,9 +94,9 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
+ while ((c = poptGetNextOpt(optCon)) >= 0) {
+ switch (c) {
+ case 'h':
+- printf(usage_message);
++ printf("%s", usage_message);
+ printf("\n");
+- printf(help_message);
++ printf("%s", help_message);
+ exit(EXIT_SUCCESS);
+
+ case 'f':
+@@ -142,7 +142,7 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
+ break;
+
+ case '?':
+- printf(usage_message);
++ printf("%s", usage_message);
+ exit(EXIT_SUCCESS);
+
+ }
+@@ -177,7 +177,7 @@ struct detox_options *parse_options_popt(int argc, const char **argv)
+
+ #ifndef INLINE_MODE
+ if (i == 0) {
+- fprintf(stderr, usage_message);
++ fprintf(stderr, "%s", usage_message);
+ exit(EXIT_FAILURE);
+ }
+ #endif
diff --git a/app-misc/detox/files/detox-1.2.0-install-missing-file.patch b/app-misc/detox/files/detox-1.2.0-install-missing-file.patch
new file mode 100644
index 00000000000..97863268bc4
--- /dev/null
+++ b/app-misc/detox/files/detox-1.2.0-install-missing-file.patch
@@ -0,0 +1,18 @@
+# Patch by Nelson A. de Oliveira <naoliv@debian.org>
+#
+# Patch upstream Makefile to install missing safe.tbl (#566785)
+
+--- detox-1.2.0/Makefile.in 2010-06-20 23:41:34.000000000 -0300
++++ detox-1.2.0/Makefile.in 2010-06-20 23:42:34.000000000 -0300
+@@ -147,6 +147,11 @@
+ else \
+ echo "${DESTDIR}${datadir}/detox/unicode.tbl exists, skipping"; \
+ fi
++ @if [ ! -f ${DESTDIR}${datadir}/detox/safe.tbl ]; then \
++ ${INSTALL} -m 644 safe.tbl ${DESTDIR}${datadir}/detox; \
++ else \
++ echo "${DESTDIR}${datadir}/detox/safe.tbl exists, skipping"; \
++ fi
+
+ install-unsafe-config: install-base
+ ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}
diff --git a/app-misc/detox/files/detox-1.2.0-parallel.patch b/app-misc/detox/files/detox-1.2.0-parallel.patch
new file mode 100644
index 00000000000..73abd73d61b
--- /dev/null
+++ b/app-misc/detox/files/detox-1.2.0-parallel.patch
@@ -0,0 +1,29 @@
+https://sourceforge.net/tracker/index.php?func=detail&aid=2166387&group_id=101612&atid=630105
+
+--- Makefile.in 2008-10-14 16:39:34 +0000
++++ Makefile.in 2008-10-14 16:38:51 +0000
+@@ -131,7 +131,7 @@
+ ${INSTALL} -m 644 detox.1 ${DESTDIR}${mandir}/man1
+ ${INSTALL} -m 644 detoxrc.5 detox.tbl.5 ${DESTDIR}${mandir}/man5
+
+-install-safe-config:
++install-safe-config: install-base
+ @if [ ! -f ${DESTDIR}${sysconfdir}/detoxrc ]; then \
+ ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}; \
+ else \
+@@ -148,12 +148,12 @@
+ echo "${DESTDIR}${datadir}/detox/unicode.tbl exists, skipping"; \
+ fi
+
+-install-unsafe-config:
++install-unsafe-config: install-base
+ ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}
+ ${INSTALL} -m 644 iso8859_1.tbl ${DESTDIR}${datadir}/detox
+ ${INSTALL} -m 644 unicode.tbl ${DESTDIR}${datadir}/detox
+
+-install-sample-config:
++install-sample-config: install-base
+ ${INSTALL} -m 644 detoxrc ${DESTDIR}${sysconfdir}/detoxrc.sample
+ ${INSTALL} -m 644 iso8859_1.tbl ${DESTDIR}${datadir}/detox/iso8859_1.tbl.sample
+ ${INSTALL} -m 644 unicode.tbl ${DESTDIR}${datadir}/detox/unicode.tbl.sample
+
diff --git a/app-misc/detox/metadata.xml b/app-misc/detox/metadata.xml
new file mode 100644
index 00000000000..73c014e4f0b
--- /dev/null
+++ b/app-misc/detox/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <upstream>
+ <remote-id type="sourceforge">detox</remote-id>
+ </upstream>
+</pkgmetadata>