summaryrefslogtreecommitdiff
path: root/app-misc/flasm
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/flasm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/flasm')
-rw-r--r--app-misc/flasm/Manifest1
-rw-r--r--app-misc/flasm/files/flasm-1.63-makefile.patch27
-rw-r--r--app-misc/flasm/flasm-1.63.ebuild42
-rw-r--r--app-misc/flasm/metadata.xml14
4 files changed, 84 insertions, 0 deletions
diff --git a/app-misc/flasm/Manifest b/app-misc/flasm/Manifest
new file mode 100644
index 00000000000..72e3b856833
--- /dev/null
+++ b/app-misc/flasm/Manifest
@@ -0,0 +1 @@
+DIST flasm-1.63.zip 111912 SHA256 df1273a506e2479cf95775197f5b7fa94e29fe1e0aae5aa190ed5bbebc4be5c6 SHA512 af53c8902bac9bc03a4274f51280abe7e595f19d8ee367c0237868634df58a42144bb6c335a99f860c494da90d483072c66064897ef1ad467b7621c648ca322a WHIRLPOOL e69860fdfa5be54235c0a02f2b77e30e4a2735b6785aa45260a2bdb55ff8a2edd366c1c9dadc93c7ac76886bd0070c4b6220a38365b6ba3135a1ade19a7ef103
diff --git a/app-misc/flasm/files/flasm-1.63-makefile.patch b/app-misc/flasm/files/flasm-1.63-makefile.patch
new file mode 100644
index 00000000000..32ea2bc0018
--- /dev/null
+++ b/app-misc/flasm/files/flasm-1.63-makefile.patch
@@ -0,0 +1,27 @@
+--- Makefile.o 2010-08-31 01:17:46.505000089 +0200
++++ Makefile 2010-08-31 01:19:11.841000098 +0200
+@@ -1,6 +1,4 @@
+ UNAME = $(shell uname)
+-CC = gcc
+-CFLAGS = -g -Wall -O2
+ LIBS = -lz
+ OFILES = util.o keywords.o flasm.o unflasm.o lex.yy.o assembler.tab.o
+ GARBAGE = assembler.tab.* lex.yy.c memwatch.o gmon.out memwatch.log core
+@@ -9,8 +7,6 @@
+ ifneq (,$(findstring debug,$(MAKECMDGOALS)))
+ CFLAGS += -DMEMWATCH -pg -p -pedantic -W -Wcast-align -Wcast-qual -Wshadow -Wnested-externs -Wstrict-prototypes -Waggregate-return -Wmissing-prototypes -Wpointer-arith
+ OFILES += memwatch.o
+-else
+- CFLAGS += -s
+ endif
+
+ # executable should not depend on cygwin.dll
+@@ -26,7 +22,7 @@
+ -rm -f ${OFILES} ${GARBAGE}
+
+ flasm: ${OFILES}
+- ${CC} $(CFLAGS) -o flasm ${OFILES} ${LIBS}
++ ${CC} $(CFLAGS) $(LDFLAGS) -o flasm ${OFILES} ${LIBS}
+
+ assembler.tab.c assembler.tab.h: assembler.y
+ bison --defines --debug assembler.y
diff --git a/app-misc/flasm/flasm-1.63.ebuild b/app-misc/flasm/flasm-1.63.ebuild
new file mode 100644
index 00000000000..19e76dbd133
--- /dev/null
+++ b/app-misc/flasm/flasm-1.63.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator toolchain-funcs
+
+MY_PV=$(delete_all_version_separators $(get_version_component_range 1-2))
+DESCRIPTION="Command line assembler/disassembler of Flash ActionScript bytecode"
+HOMEPAGE="http://www.nowrap.de/flasm.html"
+SRC_URI="http://www.nowrap.de/download/flasm${MY_PV}src.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/gperf
+ sys-devel/flex
+ virtual/yacc
+"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin flasm
+ dodoc CHANGES.TXT
+ dohtml flasm.html classic.css
+}
diff --git a/app-misc/flasm/metadata.xml b/app-misc/flasm/metadata.xml
new file mode 100644
index 00000000000..8362375232e
--- /dev/null
+++ b/app-misc/flasm/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>Flasm disassembles your entire SWF including all the
+ timelines and events. Looking at disassembly, you learn how the Flash
+ compiler works, which improves your ActionScript skills. You can also do
+ some optimizations on the disassembled code by hand or adjust the code as
+ you wish. Flasm then applies your changes to the original SWF, replacing
+ original actions.
+ </longdescription>
+</pkgmetadata>