summaryrefslogtreecommitdiff
path: root/app-misc/gnote
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-24 22:27:46 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-24 22:43:57 +0200
commit84a798b888c42d632d47913892ee3c05be0e8fc2 (patch)
tree986693103f83ebf93527075ec2a55f2160e13aaf /app-misc/gnote
parentc51554cbfecf02dcbb5d2b9b77f3a8a541ae7245 (diff)
downloadgentoo-84a798b888c42d632d47913892ee3c05be0e8fc2.tar.gz
gentoo-84a798b888c42d632d47913892ee3c05be0e8fc2.tar.xz
app-misc/gnote: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest1
-rw-r--r--app-misc/gnote/gnote-3.20.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index 9bcba6c6850..522cc2ffa29 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1 +1,2 @@
DIST gnote-3.18.1.tar.xz 3310004 SHA256 5da4ec9e7852b09af1067311fc6ee18a2c64384f4f5943b71ac37665144be58d SHA512 bd67f43494c8367a1b435a44408ed8fa7f50e380d09fedcb27874d7b38791ed65fb68e524946188859f58588625f436a58fb85d8429bd1ec1daf47328a74bc57 WHIRLPOOL 5df84e22467903159fa49eb1840b9fbfc0f8cf341ff1ff673c71cce1ebb1a5d3d85e1375d1ed21e7232f328078752153d0aa5929e8756963b65658e45fd671dd
+DIST gnote-3.20.1.tar.xz 3304760 SHA256 75acffdc2c0cc8cd226dc4471e6624d523bbd86c415ef4e05be70cbbfd4014e7 SHA512 1547442fec255579588404c17faa4ec7a8fc3445b68b55bd115b57daeb1924e77ba97b4a7b8c19979b97072912b4b761a6e7155370605a920cdc684dff5da222 WHIRLPOOL f21ea792c271ed72aa5b2f8fc420ac09abafecc421da8e98084cdbca67c2a4fec8a180883fe476d89a44f55278430d472639abd89f3b3abcd1e1aa6c5009c138
diff --git a/app-misc/gnote/gnote-3.20.1.ebuild b/app-misc/gnote/gnote-3.20.1.ebuild
new file mode 100644
index 00000000000..a87b6567e5c
--- /dev/null
+++ b/app-misc/gnote/gnote-3.20.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Automagic glib-2.32 dep
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gtkspell-3.0:3
+ >=dev-cpp/glibmm-2.32:2
+ >=dev-cpp/gtkmm-3.18:3.0
+ >=dev-libs/boost-1.34
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.16:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}