summaryrefslogtreecommitdiff
path: root/app-misc/gnote
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-19 23:57:38 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-20 00:02:28 +0200
commit9e307e43fa61f4db98531eced67bec8aecb785a9 (patch)
tree1f50aec5bf9144ff882bd81615104feec74c4d3b /app-misc/gnote
parent0892e13b9acd392d15ceeee1edf51f0c96698292 (diff)
downloadgentoo-9e307e43fa61f4db98531eced67bec8aecb785a9.tar.gz
gentoo-9e307e43fa61f4db98531eced67bec8aecb785a9.tar.xz
app-misc/gnote: version bump 3.20.2 → 3.22.0
Package-Manager: portage-2.3.1
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest1
-rw-r--r--app-misc/gnote/gnote-3.22.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index 17a7deca6e3..de6bababe9a 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1,2 +1,3 @@
DIST gnote-3.20.1.tar.xz 3304760 SHA256 75acffdc2c0cc8cd226dc4471e6624d523bbd86c415ef4e05be70cbbfd4014e7 SHA512 1547442fec255579588404c17faa4ec7a8fc3445b68b55bd115b57daeb1924e77ba97b4a7b8c19979b97072912b4b761a6e7155370605a920cdc684dff5da222 WHIRLPOOL f21ea792c271ed72aa5b2f8fc420ac09abafecc421da8e98084cdbca67c2a4fec8a180883fe476d89a44f55278430d472639abd89f3b3abcd1e1aa6c5009c138
DIST gnote-3.20.2.tar.xz 3304528 SHA256 fdc76ae31dc8925545806c1702cf74e1c8f387b16519ed995987194f688555eb SHA512 59d28a8e9069abfbb0f9d29be31d31d39406b374bf9fce434cdb626b508faace5a7505d5fd08196fba938059d7100d85c837a71d97a27345ddf439c569aabc91 WHIRLPOOL 7ae787a43cc6e66400b607f68d2153a0c5651389a134b6870603aacfd278f06d06e41cc147c8f556936b5a85c807d606a44fcd09ce490415d135f614945ae392
+DIST gnote-3.22.0.tar.xz 3309040 SHA256 fc2f562c08f29eec8b6c6985ed936bd62dc90388d8f06c3be59767bfe2f5f656 SHA512 78a4441fb7fe744f266031aaad316e6d4f9f83e866e0033fc50478a8e126ef17227c2e11bf63afd289873c92af10277afcce77963616acbe273d46cf0c3b133d WHIRLPOOL 2d50890f0efaf9b0f4e2056aed5d5e264a809d4e5e4189449147940dbba16a888a8a291a300206d4df7083562d8e50320d711e072c89481cae6a660ddc5dce76
diff --git a/app-misc/gnote/gnote-3.22.0.ebuild b/app-misc/gnote/gnote-3.22.0.ebuild
new file mode 100644
index 00000000000..7385afc4de9
--- /dev/null
+++ b/app-misc/gnote/gnote-3.22.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Automagic glib-2.32 dep
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gtkspell-3.0:3
+ >=dev-cpp/glibmm-2.32:2
+ >=dev-cpp/gtkmm-3.18:3.0
+ >=dev-libs/boost-1.34:=
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.20:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}