summaryrefslogtreecommitdiff
path: root/app-misc/ifp-line
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/ifp-line
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/ifp-line')
-rw-r--r--app-misc/ifp-line/Manifest1
-rw-r--r--app-misc/ifp-line/files/ifp-line-0.3-fix-warnings.patch30
-rw-r--r--app-misc/ifp-line/ifp-line-0.3.ebuild43
-rw-r--r--app-misc/ifp-line/metadata.xml8
4 files changed, 82 insertions, 0 deletions
diff --git a/app-misc/ifp-line/Manifest b/app-misc/ifp-line/Manifest
new file mode 100644
index 00000000000..577df739b5c
--- /dev/null
+++ b/app-misc/ifp-line/Manifest
@@ -0,0 +1 @@
+DIST ifp-line-0.3.tar.gz 138272 SHA256 2d44807abbd5d2202d253b550b867dfa3776a71bf6d3f202b0f1254e66325257 SHA512 516ad85fdaf69111581b013b2517c7083656436d429a86ec5ca4b7dcaf1c841538f98138cce8839d990a34550f11cc6bc9dedc701b0123b9cb73a91a7d78694d WHIRLPOOL 868dc9508086a4ba76620d682e1702dded82bf69cd19e42667dac239c6825d0dfb01aaa30d5560e9fe670bf735479b88cae816ab58daa1dacbebe03fa01c05e6
diff --git a/app-misc/ifp-line/files/ifp-line-0.3-fix-warnings.patch b/app-misc/ifp-line/files/ifp-line-0.3-fix-warnings.patch
new file mode 100644
index 00000000000..f7fe1de4b1f
--- /dev/null
+++ b/app-misc/ifp-line/files/ifp-line-0.3-fix-warnings.patch
@@ -0,0 +1,30 @@
+--- unicodehack.c.orig 2006-01-31 20:18:16.000000000 -0500
++++ unicodehack.c 2006-01-31 20:18:39.000000000 -0500
+@@ -26,7 +26,7 @@
+ return -1;
+ }
+
+- if ( (retval = iconv(cd, (const char **)&src, &srcln, &dst, &dstln)) == -1) {
++ if ( (retval = iconv(cd, (char **)&src, &srcln, &dst, &dstln)) == -1) {
+ // XXX ignore error message "iconv: Illiegal byte sequence"
+ // with GNU libiconv. No effect for output in now.
+ //perror("iconv");
+@@ -43,7 +43,7 @@
+ /**
+ * @return less then zero: error.
+ */
+-int unicode2locale(char *dst, size_t dstln, const char *src, size_t srcln) {
++int unicode2locale(char *dst, size_t dstln, char *src, size_t srcln) {
+ iconv_t cd;
+ int retval;
+
+--- unicodehack.h.orig 2006-01-31 20:19:05.000000000 -0500
++++ unicodehack.h 2006-01-31 20:19:26.000000000 -0500
+@@ -4,6 +4,6 @@
+ #define IFPLINE_UNICODEHACK_H
+
+ extern int locale2unicode(char*, size_t, const char*, size_t);
+-extern int unicode2locale(char*, size_t, const char*, size_t);
++extern int unicode2locale(char*, size_t, char*, size_t);
+
+ #endif // IFPLINE_UNICODEHACK_H
diff --git a/app-misc/ifp-line/ifp-line-0.3.ebuild b/app-misc/ifp-line/ifp-line-0.3.ebuild
new file mode 100644
index 00000000000..2b5e596348a
--- /dev/null
+++ b/app-misc/ifp-line/ifp-line-0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="iRiver iFP open-source driver"
+HOMEPAGE="http://ifp-driver.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ifp-driver/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="virtual/libusb:0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-warnings.patch
+}
+
+src_install() {
+ dobin ifp || die
+ dodoc NEWS README TIPS ChangeLog
+ doman ifp.1
+
+ exeinto /usr/share/${PN}
+ doexe nonroot.sh || die
+}
+
+pkg_postinst() {
+ elog
+ elog "To enable non-root usage of ${PN}, you use any of the following"
+ elog "methods."
+ elog
+ elog " 1. Follow the TIPS file in"
+ elog " /usr/share/doc/${PF}"
+ elog
+ elog " 2. Run /usr/share/${PN}/nonroot.sh"
+ elog
+}
diff --git a/app-misc/ifp-line/metadata.xml b/app-misc/ifp-line/metadata.xml
new file mode 100644
index 00000000000..74257d7e3e8
--- /dev/null
+++ b/app-misc/ifp-line/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">ifp-driver</remote-id>
+ </upstream>
+</pkgmetadata>