summaryrefslogtreecommitdiff
path: root/app-misc/lirc
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-04-06 14:45:07 -0400
committerCraig Andrews <candrews@gentoo.org>2018-04-06 14:45:07 -0400
commit856720e8b9d8584e294d58737caaf6ecb2905928 (patch)
tree53e035a858736635ff95b9272dbe663a32885c55 /app-misc/lirc
parenta935cdc170bcda534ad01824d600c13f03804e66 (diff)
downloadgentoo-856720e8b9d8584e294d58737caaf6ecb2905928.tar.gz
gentoo-856720e8b9d8584e294d58737caaf6ecb2905928.tar.xz
app-misc/lirc: 0.10.0 version bump
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'app-misc/lirc')
-rw-r--r--app-misc/lirc/Manifest1
-rw-r--r--app-misc/lirc/lirc-0.10.0.ebuild151
2 files changed, 152 insertions, 0 deletions
diff --git a/app-misc/lirc/Manifest b/app-misc/lirc/Manifest
index 56886326f30..640fb7f681a 100644
--- a/app-misc/lirc/Manifest
+++ b/app-misc/lirc/Manifest
@@ -1,4 +1,5 @@
DIST lirc-0.10.0-rc2.tar.bz2 2552982 BLAKE2B d68639198dd7041865f6b7ac79cb94b63d8a85ee70f97628e27887d14f62814388a51521dabe91730570c382c6bb7edb36c15eba0f8ea9f5d4490dfce2bd121a SHA512 ab3426477f017e3a1b9da690189beae5086bbb52f88d302e6c91d7633f74ef781e6747f6b697b3ed6df13497a3e666f11c846104d2f00b975746d24bfd2a6cd5
+DIST lirc-0.10.0.tar.bz2 2523528 BLAKE2B 5c133b40936060fbaa0a9463b1b07d9197d935388e3eb4e46791b1f844b82ea6b6d42ae0c6ce249ca306688fa5d15718f5a3a54b497fc9f168b8b736b06bdd1e SHA512 06ccc1c8c80bfd17a6d180ae39a17779cbba341086f90a03a2e552bfb71e3abcb13f991312fba0e57df79c1882c1e29a2f273dddcd46a9ff53160b556e1547ab
DIST lirc-0.9.0.tar.bz2 857286 BLAKE2B 034c7b8492dd42301bb6d40da8c6c95f714b925ee50e7396290231684024dc3fe3bb64987db92d2a4e4d56203436007e68222bbf9a775bb9d29bbefcc4a7c1e4 SHA512 e91534c63e6065bd7da3b15e1676edf1672b8beb21864a6825df86247d7d165bf2dee6f8191732933e24e42a406e46afc55559948e4061eed2de7b08fac13431
DIST lirc-0.9.4a.tar.bz2 2292119 BLAKE2B 6ca7562716fde3327aa3f8f9913da7d349969f1bcac095bf2e9b1e3025d1e39176e2fb386ca08bcf80d458262f9eb96dab363ef3aa2c1d56b914ac8a36fcbacf SHA512 16be0ac5dd9b07d717ceba63cdc38c0db4a2bdcfc373ca6346d7cd4ab2cd2973aa7585d10b045fcaea952a3aabf7617c564ccb8268db6c62b172683a4b2cc188
DIST lirc-0.9.4c.tar.bz2 2311300 BLAKE2B f58f3b3a701e0ae787e34ec65c1d29b0faa75958b95aa43663a78dbe04c1c1d5456df5a6c5e41c673db9f589a7c2d41423b5f6a667fac890fb18f29fd797438b SHA512 0a0d0e025b87a55ec919c92824d8288bfaf35cfebae0ee97d86e344109f584baa72a2eff6d24fbc526900671d6092e0eebef8d1566559b0d153e122e3127c0cb
diff --git a/app-misc/lirc/lirc-0.10.0.ebuild b/app-misc/lirc/lirc-0.10.0.ebuild
new file mode 100644
index 00000000000..8ddbc22037b
--- /dev/null
+++ b/app-misc/lirc/lirc-0.10.0.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit eutils flag-o-matic linux-info python-single-r1 systemd xdg-utils
+
+DESCRIPTION="decode and send infra-red signals of many commonly used remote controls"
+HOMEPAGE="http://www.lirc.org/"
+
+LIRC_DRIVER_DEVICE="/dev/lirc0"
+
+MY_P=${PN}-${PV/_/-}
+
+if [[ "${PV/_pre/}" = "${PV}" ]]; then
+ SRC_URI="mirror://sourceforge/lirc/${MY_P}.tar.bz2"
+else
+ SRC_URI="http://www.lirc.org/software/snapshots/${MY_P}.tar.bz2"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="audio +devinput doc ftdi gtk inputlirc static-libs systemd +uinput usb X"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ gtk? ( X )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ audio? (
+ >media-libs/portaudio-18
+ media-libs/alsa-lib
+ )
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ ftdi? ( dev-embedded/libftdi:0 )
+ systemd? ( sys-apps/systemd )
+ usb? ( virtual/libusb:0 )
+ X? (
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ )
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/libxslt
+ doc? ( app-doc/doxygen )
+ sys-apps/kmod
+ sys-kernel/linux-headers
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ gtk? (
+ x11-libs/vte[introspection]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ )
+ inputlirc? ( app-misc/inputlircd )
+"
+
+pkg_setup() {
+ use uinput && CONFIG_CHECK="INPUT_UINPUT"
+}
+
+src_configure() {
+ xdg_environment_reset
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable static-libs static) \
+ $(use_enable devinput) \
+ $(use_enable uinput) \
+ $(use_with X x)
+}
+
+src_install() {
+ default
+
+ if use !gtk ; then
+ # lirc-setup requires gtk
+ rm "${ED%/}"/usr/bin/lirc-setup || die
+ fi
+
+ newinitd "${FILESDIR}"/lircd-0.8.6-r2 lircd
+ newinitd "${FILESDIR}"/lircmd-0.9.4a-r2 lircmd
+ newconfd "${FILESDIR}"/lircd.conf.4 lircd
+ newconfd "${FILESDIR}"/lircmd-0.10.0.conf lircmd
+
+ insinto /etc/modprobe.d/
+ newins "${FILESDIR}"/modprobed.lirc lirc.conf
+
+ newinitd "${FILESDIR}"/irexec-initd-0.9.4a-r2 irexec
+ newconfd "${FILESDIR}"/irexec-confd irexec
+
+ keepdir /etc/lirc
+ if [[ -e "${ED%/}"/etc/lirc/lircd.conf ]]; then
+ newdoc "${ED%/}"/etc/lirc/lircd.conf lircd.conf.example
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+
+ # Avoid QA notice
+ rm -d "${ED%/}"/var/run/lirc || die
+ rm -d "${ED%/}"/var/run || die
+}
+
+pkg_preinst() {
+ local dir="${EROOT%/}/etc/modprobe.d"
+ if [[ -a "${dir}"/lirc && ! -a "${dir}"/lirc.conf ]]; then
+ elog "Renaming ${dir}/lirc to lirc.conf"
+ mv -f "${dir}/lirc" "${dir}/lirc.conf" || die
+ fi
+
+ # copy the first file that can be found
+ if [[ -f "${EROOT%/}"/etc/lirc/lircd.conf ]]; then
+ cp "${EROOT%/}"/etc/lirc/lircd.conf "${T}"/lircd.conf || die
+ elif [[ -f "${EROOT%/}"/etc/lircd.conf ]]; then
+ cp "${EROOT%/}"/etc/lircd.conf "${T}"/lircd.conf || die
+ MOVE_OLD_LIRCD_CONF=1
+ elif [[ -f "${ED%/}"/etc/lirc/lircd.conf ]]; then
+ cp "${ED%/}"/etc/lirc/lircd.conf "${T}"/lircd.conf || die
+ fi
+
+ # stop portage from touching the config file
+ if [[ -e "${ED%/}"/etc/lirc/lircd.conf ]]; then
+ rm -f "${ED%/}"/etc/lirc/lircd.conf || die
+ fi
+}
+
+pkg_postinst() {
+ # copy config file to new location
+ # without portage knowing about it
+ # so it will not delete it on unmerge or ever touch it again
+ if [[ -e "${T}"/lircd.conf ]]; then
+ cp "${T}"/lircd.conf "${EROOT%/}"/etc/lirc/lircd.conf || die
+ if [[ "$MOVE_OLD_LIRCD_CONF" = "1" ]]; then
+ elog "Moved /etc/lircd.conf to /etc/lirc/lircd.conf"
+ rm -f "${EROOT%/}"/etc/lircd.conf || die
+ fi
+ fi
+
+ einfo "The new default location for lircd.conf is inside of"
+ einfo "${EROOT%/}/etc/lirc/ directory"
+}