summaryrefslogtreecommitdiff
path: root/app-misc/lockfile-progs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/lockfile-progs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/lockfile-progs')
-rw-r--r--app-misc/lockfile-progs/Manifest2
-rw-r--r--app-misc/lockfile-progs/files/Makefile55
-rw-r--r--app-misc/lockfile-progs/lockfile-progs-0.1.16.ebuild25
-rw-r--r--app-misc/lockfile-progs/lockfile-progs-0.1.17.ebuild35
-rw-r--r--app-misc/lockfile-progs/metadata.xml8
5 files changed, 125 insertions, 0 deletions
diff --git a/app-misc/lockfile-progs/Manifest b/app-misc/lockfile-progs/Manifest
new file mode 100644
index 00000000000..743f4f12401
--- /dev/null
+++ b/app-misc/lockfile-progs/Manifest
@@ -0,0 +1,2 @@
+DIST lockfile-progs_0.1.16.tar.gz 155901 SHA256 f95132d632687af971da830497f06257fa86aedbc4b76874456652f06a0a8a69 SHA512 374879dbfeb1f0e555a2fa0fa3ea77cbee0a70a492d52695b9b7bce284c0a8b7878978d64d6ec03d2cd6799f31a6a3e6bac7d00d857f90a08acda2e74ef6dee4 WHIRLPOOL 76b26ddf865db1fd83728958a453906860bc1a11e532aed0ad635c9ff887a9bca670314849f059c78319ce7c23176c9f17b662d629ce3574db0effb3f51c89b8
+DIST lockfile-progs_0.1.17.tar.gz 14833 SHA256 03fb05d25499532f497775b1747b61fa6beebf12d3bcc951e125349ae166c511 SHA512 9d912e1a518fe9c02054beb25c4591df6db55cc2fe9b7049fb85368465bd9ced9660bb0a809ee60a7effbdc6524613c40fa69d9d27fc2cfc964f41b7486c3596 WHIRLPOOL 7fc3febe9c495ba9aaefc8924f17c955c506169d00ea372ceae71e7e594478c1d15283b80dd6f8f9b27e82a86d9984b4a4aa96586316a4fb8dff5169072ed64f
diff --git a/app-misc/lockfile-progs/files/Makefile b/app-misc/lockfile-progs/files/Makefile
new file mode 100644
index 00000000000..27276b30f5d
--- /dev/null
+++ b/app-misc/lockfile-progs/files/Makefile
@@ -0,0 +1,55 @@
+all: lockfile-create
+
+lockfile-create: lockfile-progs.o
+ ${CC} -o $@ ${CFLAGS} ${LDFLAGS} $^ -llockfile
+
+install: all
+ install -d $(DESTDIR)/usr/bin
+
+ install --mode=755 lockfile-create $(DESTDIR)/usr/bin/lockfile-create
+ ln -s lockfile-create $(DESTDIR)/usr/bin/lockfile-remove
+ ln -s lockfile-create $(DESTDIR)/usr/bin/lockfile-touch
+ ln -s lockfile-create $(DESTDIR)/usr/bin/lockfile-check
+
+ install --mode=755 lockfile-create $(DESTDIR)/usr/bin/mail-lock
+ ln -s mail-lock $(DESTDIR)/usr/bin/mail-unlock
+ ln -s mail-unlock $(DESTDIR)/usr/bin/mail-touchlock
+
+ install -d $(DESTDIR)/usr/share/man/man1
+
+ install --mode=644 lockfile-progs.1 $(DESTDIR)/usr/share/man/man1
+ ln -s lockfile-progs.1 $(DESTDIR)/usr/share/man/man1/lockfile-create.1
+ ln -s lockfile-progs.1 $(DESTDIR)/usr/share/man/man1/lockfile-remove.1
+ ln -s lockfile-progs.1 $(DESTDIR)/usr/share/man/man1/lockfile-touch.1
+ ln -s lockfile-progs.1 $(DESTDIR)/usr/share/man/man1/lockfile-check.1
+
+ ln -s lockfile-progs.1 $(DESTDIR)/usr/share/man/man1/mail-lock.1
+ ln -s lockfile-progs.1 $(DESTDIR)/usr/share/man/man1/mail-unlock.1
+ ln -s lockfile-progs.1 $(DESTDIR)/usr/share/man/man1/mail-touchlock.1
+
+test: all
+ ln -s lockfile-create ./lockfile-remove
+ ln -s lockfile-create ./lockfile-touch
+ ln -s lockfile-create ./lockfile-check
+
+ ./lockfile-create testfile
+ ./lockfile-check testfile
+ ./lockfile-touch --oneshot testfile
+ ./lockfile-check testfile
+ ./lockfile-remove testfile
+ ! test -e testfile
+ ! ./lockfile-check testfile
+
+ ./lockfile-create --lock-name test.lock
+ ./lockfile-check --lock-name test.lock
+ ! ./lockfile-check test.lock
+ ! test -e test.lock.lock
+ ./lockfile-touch --oneshot --lock-name test.lock
+ ./lockfile-check --lock-name test.lock
+ ! ./lockfile-check test.lock
+ ./lockfile-remove --lock-name test.lock
+ ! test -e test.lock
+ ! ./lockfile-check --lock-name test.lock
+ ! ./lockfile-check test.lock
+
+.PHONY: install test
diff --git a/app-misc/lockfile-progs/lockfile-progs-0.1.16.ebuild b/app-misc/lockfile-progs/lockfile-progs-0.1.16.ebuild
new file mode 100644
index 00000000000..63260413036
--- /dev/null
+++ b/app-misc/lockfile-progs/lockfile-progs-0.1.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Programs to safely lock/unlock files and mailboxes"
+HOMEPAGE="http://packages.debian.org/sid/lockfile-progs"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc s390 sh sparc x86"
+IUSE=""
+
+DEPEND="net-libs/liblockfile"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/main"
+
+src_prepare() {
+ # Provide better Makefile, with clear separation between compilation
+ # and installation.
+ cp "${FILESDIR}/Makefile" . || die
+}
diff --git a/app-misc/lockfile-progs/lockfile-progs-0.1.17.ebuild b/app-misc/lockfile-progs/lockfile-progs-0.1.17.ebuild
new file mode 100644
index 00000000000..4daf115a590
--- /dev/null
+++ b/app-misc/lockfile-progs/lockfile-progs-0.1.17.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Programs to safely lock/unlock files and mailboxes"
+HOMEPAGE="http://packages.debian.org/sid/lockfile-progs"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc ~s390 ~sh sparc x86"
+IUSE=""
+
+DEPEND="net-libs/liblockfile"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Provide better Makefile, with clear separation between compilation
+ # and installation.
+ cp "${FILESDIR}/Makefile" . || die
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ # Makefile has no notion of PREFIX, bindir, and the like
+ emake DESTDIR="${ED}" install || die
+}
diff --git a/app-misc/lockfile-progs/metadata.xml b/app-misc/lockfile-progs/metadata.xml
new file mode 100644
index 00000000000..d047926ffe0
--- /dev/null
+++ b/app-misc/lockfile-progs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>phajdan.jr@gentoo.org</email>
+ <name>Pawel Hajdan jr</name>
+ </maintainer>
+</pkgmetadata>