summaryrefslogtreecommitdiff
path: root/app-misc/media-player-info
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/media-player-info
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/media-player-info')
-rw-r--r--app-misc/media-player-info/Manifest2
-rw-r--r--app-misc/media-player-info/files/media-player-info-21-udev.patch20
-rw-r--r--app-misc/media-player-info/media-player-info-21-r1.ebuild43
-rw-r--r--app-misc/media-player-info/media-player-info-22.ebuild37
-rw-r--r--app-misc/media-player-info/metadata.xml5
5 files changed, 107 insertions, 0 deletions
diff --git a/app-misc/media-player-info/Manifest b/app-misc/media-player-info/Manifest
new file mode 100644
index 00000000000..55cf4010944
--- /dev/null
+++ b/app-misc/media-player-info/Manifest
@@ -0,0 +1,2 @@
+DIST media-player-info-21.tar.gz 103224 SHA256 eae5a41d27715c9280128ff770a491dae2e73e2ebeef41630b069ad0d4795127 SHA512 d281984cd746984a4b618478d9fdc3249ad4f84c38d4c6486cbf9f50d44d1ca089d8950989e34157139560b97b0093befb34a7dc465121af37dc3cbf26f04bb5 WHIRLPOOL 18b32b6dabafbdc3697af7285b373bd87bd7f3f087d7344170e99428374d57e25efbaafdc703d4b587dd2addc29701afbf352282fe2f10ffb7b8fbe5589edf5a
+DIST media-player-info-22.tar.gz 104833 SHA256 7ee7d7712834860533c46b16947238ef5b5d72f394fa7fb52783a15fba7b2336 SHA512 7686aadb559b5a2cd2b969b9aadcf4c2b35037702e6fef4db66c6b8c0860d400c9f46a3b46150b9ce573d4f1fca53a5302fa7c1cdf888942a6489613c4d3c071 WHIRLPOOL 65994db840df66a9fa1b819fae743f3c14e50591b36fe2d56a6a92346746cb0db1b5f2822944b0e2caa35a198fcf56fbd2af4aee62cc85053e4b3134f41eb977
diff --git a/app-misc/media-player-info/files/media-player-info-21-udev.patch b/app-misc/media-player-info/files/media-player-info-21-udev.patch
new file mode 100644
index 00000000000..fd2fe4b28af
--- /dev/null
+++ b/app-misc/media-player-info/files/media-player-info-21-udev.patch
@@ -0,0 +1,20 @@
+From 952a7e728356681f019f3a5076169daa24b946b9 Mon Sep 17 00:00:00 2001
+From: Martin Pitt <martinpitt@gnome.org>
+Date: Mon, 30 Sep 2013 12:07:49 +0000
+Subject: Terminate udev rules with an empty line
+
+Apparently newer udev versions now complain about the lack of it. Reported by
+Frederic Crozat.
+---
+diff --git a/tools/mpi2udev.py b/tools/mpi2udev.py
+index d33055b..33fdfa2 100755
+--- a/tools/mpi2udev.py
++++ b/tools/mpi2udev.py
+@@ -126,4 +126,4 @@ for f in sys.argv[2:]:
+ parse_mpi(f, hwdb)
+
+ # udev rules footer
+-os.write(sys.stdout.fileno(), b'\nLABEL="media_player_end"')
++os.write(sys.stdout.fileno(), b'\nLABEL="media_player_end"\n')
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/app-misc/media-player-info/media-player-info-21-r1.ebuild b/app-misc/media-player-info/media-player-info-21-r1.ebuild
new file mode 100644
index 00000000000..5298d99fd1a
--- /dev/null
+++ b/app-misc/media-player-info/media-player-info-21-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit eutils python-any-r1
+
+DESCRIPTION="A repository of data files describing media player capabilities"
+HOMEPAGE="http://cgit.freedesktop.org/media-player-info/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sh ~sparc x86"
+IUSE=""
+
+# http://cgit.freedesktop.org/media-player-info/commit/?id=d83dd01a0a1df6198ee08954da1c033b88a1004b
+RDEPEND=">=virtual/udev-208"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-udev.patch
+}
+
+pkg_postinst() {
+ # Run for /lib/udev/hwdb.d/20-usb-media-players.hwdb
+ udevadm hwdb --update --root="${ROOT%/}"
+ # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+ return 0
+ fi
+ udevadm control --reload
+}
diff --git a/app-misc/media-player-info/media-player-info-22.ebuild b/app-misc/media-player-info/media-player-info-22.ebuild
new file mode 100644
index 00000000000..57e5f6a8093
--- /dev/null
+++ b/app-misc/media-player-info/media-player-info-22.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit eutils python-any-r1
+
+DESCRIPTION="A repository of data files describing media player capabilities"
+HOMEPAGE="http://cgit.freedesktop.org/media-player-info/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+# http://cgit.freedesktop.org/media-player-info/commit/?id=d83dd01a0a1df6198ee08954da1c033b88a1004b
+RDEPEND=">=virtual/udev-208"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+pkg_postinst() {
+ # Run for /lib/udev/hwdb.d/20-usb-media-players.hwdb
+ udevadm hwdb --update --root="${ROOT%/}"
+ # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+ return 0
+ fi
+ udevadm control --reload
+}
diff --git a/app-misc/media-player-info/metadata.xml b/app-misc/media-player-info/metadata.xml
new file mode 100644
index 00000000000..941d094fcec
--- /dev/null
+++ b/app-misc/media-player-info/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>freedesktop</herd>
+</pkgmetadata>